aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-20 21:25:58 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-05-20 21:53:51 +0000
commit3f2436c02e8314614dda02f9ef9f5a13de6d18c2 (patch)
tree94e7c6c710a750ef12c6d2aceaa1bd28f3d07daa
parentaa8d1b3f0cf8c9e7b6dece28f8e1ea4cc00a2145 (diff)
downloadports-3f2436c02e8314614dda02f9ef9f5a13de6d18c2.tar.gz
ports-3f2436c02e8314614dda02f9ef9f5a13de6d18c2.zip
devel/py-gevent: Convert post-patch to EXTRACT_AFTER_ARGS
Reduces I/O by not extracting files at all Remove reference to src/gevent/_util_py2.py as it's no longer distributed PR: 278737 Approved by: portmgr (maintainer timeout, 2+ weeks)
-rw-r--r--devel/py-gevent/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/py-gevent/Makefile b/devel/py-gevent/Makefile
index fc7c2bc3da29..b83801d10978 100644
--- a/devel/py-gevent/Makefile
+++ b/devel/py-gevent/Makefile
@@ -33,14 +33,12 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR
USES= compiler:c11 localbase python
USE_PYTHON= autoplist concurrent pep517
+EXTRACT_AFTER_ARGS= --exclude ${DISTNAME}/deps \
+ --no-same-owner --no-same-permissions
+
MAKE_ENV= GEVENTSETUP_EMBED_CARES=0 GEVENTSETUP_EMBED_LIBEV=0 GEVENTSETUP_EMBED_LIBUV=0
TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
-post-patch:
- @${RM} ${WRKSRC}/src/gevent/_util_py2.py
-# Clean up bundled libraries
- @${RM} -r ${WRKSRC}/deps/
-
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +