aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 13:59:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 13:59:31 +0000
commit3f37756deff5fe2e362806ad923980bd6f866e66 (patch)
tree2a9f3160577ae2e272a1a428b2f2a20d72df4c94
parent7895e61512df28017f3ea9af4404dfc614843507 (diff)
downloadports-3f37756deff5fe2e362806ad923980bd6f866e66.tar.gz
ports-3f37756deff5fe2e362806ad923980bd6f866e66.zip
devel/py-pyicu: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-pyicu/Makefile6
-rw-r--r--devel/py-pyicu/files/patch-setup.py11
2 files changed, 15 insertions, 2 deletions
diff --git a/devel/py-pyicu/Makefile b/devel/py-pyicu/Makefile
index 01044df6fbc9..4a5794bdde2f 100644
--- a/devel/py-pyicu/Makefile
+++ b/devel/py-pyicu/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pyicu
PORTVERSION= 2.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,10 +13,12 @@ WWW= https://gitlab.pyicu.org/main/pyicu
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libicudata.so:devel/icu
USES= compiler:c++11-lang pkgconfig python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
diff --git a/devel/py-pyicu/files/patch-setup.py b/devel/py-pyicu/files/patch-setup.py
new file mode 100644
index 000000000000..eec98a2b83da
--- /dev/null
+++ b/devel/py-pyicu/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2023-11-01 20:05:58 UTC
++++ setup.py
+@@ -250,7 +250,7 @@ if sys.version_info < (2, 4):
+ return iterable
+
+
+-setup(name="PyICU",
++setup(name="pyicu",
+ description='Python extension wrapping the ICU C++ API',
+ long_description=open('README.md').read(),
+ long_description_content_type="text/markdown",