aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2021-11-11 23:50:35 +0000
committerBrooks Davis <brooks@FreeBSD.org>2021-11-11 23:50:35 +0000
commit3f4163a191133d25b424dff14a6cde8d89c34e65 (patch)
tree2286d580fe1f721b8549a61ee9c7e4c6f1523969
parent717c3a90c54f8f61d391ebe23ef52c27ce945f46 (diff)
downloadports-3f4163a191133d25b424dff14a6cde8d89c34e65.tar.gz
ports-3f4163a191133d25b424dff14a6cde8d89c34e65.zip
devel/llvm13: fix install with MLIR disabled
PR: 259570 (reported here, but tangential) Reported by: stephen
-rw-r--r--devel/llvm13/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/devel/llvm13/Makefile b/devel/llvm13/Makefile
index 1cd59bae67e7..1e188371c6cd 100644
--- a/devel/llvm13/Makefile
+++ b/devel/llvm13/Makefile
@@ -538,6 +538,9 @@ post-install-DOCS-on:
${RM} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/lit.1
${RM} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/FileCheck.1
.endif
+.if ! ${PORT_OPTIONS:MMLIR}
+ ${RM} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/mlir-tblgen.1
+.endif
${RMDIR} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/
${RMDIR} ${STAGEDIR}${LLVM_PREFIX}/share/man/