aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose G. Juanino <jjuanino@gmail.com>2021-11-23 16:48:46 +0000
committerFernando Apesteguía <fernape@FreeBSD.org>2021-11-24 06:50:46 +0000
commit3f6d136d1c1054dcfcbc728fca06d73476112c22 (patch)
tree8e8149ba0081c8726fe202f703cb82f7ee726adf
parentf10d7de2125b711fb628c6a29e42b7f8246d43a5 (diff)
downloadports-3f6d136d1c1054dcfcbc728fca06d73476112c22.tar.gz
ports-3f6d136d1c1054dcfcbc728fca06d73476112c22.zip
editors/xmlcopyeditor: update to 1.3.0.0
ChangeLog: https://sourceforge.net/p/xml-copy-editor/code/ci/master/tree/ChangeLog?format=raw PR: 259680 Reported by: jjuanino@gmail.com (maintainer)
-rw-r--r--editors/xmlcopyeditor/Makefile31
-rw-r--r--editors/xmlcopyeditor/distinfo5
-rw-r--r--editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff10
-rw-r--r--editors/xmlcopyeditor/files/patch-src_Makefile.in.diff11
-rw-r--r--editors/xmlcopyeditor/files/patch-src_myipc.cpp11
-rw-r--r--editors/xmlcopyeditor/pkg-plist16
6 files changed, 26 insertions, 58 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index c7f5a76dea68..d66c7370421a 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -1,8 +1,5 @@
-# Created by: José García Juanino <jjuanino@gmail.com>
-
PORTNAME= xmlcopyeditor
-PORTVERSION= 1.2.1.3
-PORTREVISION= 17
+PORTVERSION= 1.3.0.0
CATEGORIES= editors
MASTER_SITES= SF/xml-copy-editor/${PORTNAME}-linux/${PORTVERSION}
@@ -12,22 +9,26 @@ COMMENT= Fast validating XML editor
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-LIB_DEPENDS= libxerces-c.so.3:textproc/xerces-c3 \
- libxslt.so:textproc/libxslt \
- libaspell.so:textproc/aspell \
+LIB_DEPENDS= libaspell.so:textproc/aspell \
+ libenchant.so:textproc/enchant \
+ libexpat.so:textproc/expat2 \
+ libharfbuzz.so:print/harfbuzz \
libpcre.so:devel/pcre \
+ libxerces-c.so.3:textproc/xerces-c3 \
libxml2.so:textproc/libxml2 \
- libexpat.so:textproc/expat2
+ libxslt.so:textproc/libxslt
-USES= compiler:c++11-lang dos2unix gettext gmake gnome iconv libtool
-USE_WX= 2.8+
-WX_COMPS= wx contrib
+USES= autoreconf compiler:c++11-lang desktop-file-utils dos2unix \
+ gmake gettext-tools gnome iconv libtool pkgconfig
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 intltool pango
+USE_WX= 3.0+
+WX_COMPS= wx
WX_CONF_ARGS= absolute
-USE_GNOME= intltool
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-nls # NLS does not work properly
+
+CPPFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/libxml2
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib ${ICONV_LIB}
+WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.mk>
diff --git a/editors/xmlcopyeditor/distinfo b/editors/xmlcopyeditor/distinfo
index 6d70a5c750ae..66b292cee3ac 100644
--- a/editors/xmlcopyeditor/distinfo
+++ b/editors/xmlcopyeditor/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xmlcopyeditor-1.2.1.3.tar.gz) = 9b684b5042b4af85d3626fd55108bd1d63c0007b5c794ef7cc4b026012b29d2f
-SIZE (xmlcopyeditor-1.2.1.3.tar.gz) = 4266907
+TIMESTAMP = 1636138025
+SHA256 (xmlcopyeditor-1.3.0.0.tar.gz) = 62342d8b30cb0c59f7fd13a107619a2f955e12bb1057ecdf378b449e96ed3452
+SIZE (xmlcopyeditor-1.3.0.0.tar.gz) = 4981894
diff --git a/editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff b/editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff
deleted file mode 100644
index 80a1d98a5d43..000000000000
--- a/editors/xmlcopyeditor/files/patch-po_Makefile.in.in.diff
+++ /dev/null
@@ -1,10 +0,0 @@
-+++ po/Makefile.in.in
-@@ -34,7 +34,7 @@
- datarootdir = @datarootdir@
- libdir = @libdir@
- DATADIRNAME = @DATADIRNAME@
--itlocaledir = $(prefix)/$(DATADIRNAME)/locale
-+itlocaledir = @localedir@
- subdir = po
- install_sh = @install_sh@
- # Automake >= 1.8 provides @mkdir_p@.
diff --git a/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff b/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
index 8dcd697033d5..68915a1e1be7 100644
--- a/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
+++ b/editors/xmlcopyeditor/files/patch-src_Makefile.in.diff
@@ -1,7 +1,8 @@
-+++ src/Makefile.in
-@@ -283,8 +283,8 @@
- # these are the headers for your project
- noinst_HEADERS = $(srcdir)/*.h
+--- src/Makefile.am.orig 2021-11-05 21:58:53 UTC
++++ src/Makefile.am
+@@ -9,8 +9,8 @@ noinst_HEADERS = $(srcdir)/*.h
+ bin_PROGRAMS = xmlcopyeditor
+ bindir = ${prefix}/bin
xmlcopyeditordir = ${prefix}/share/xmlcopyeditor
-pixmapdir = /usr/share/pixmaps
-applicationsdir = /usr/share/applications
@@ -9,4 +10,4 @@
+applicationsdir = ${prefix}/share/applications
# the application source, library search path, and link libraries
- xmlcopyeditor_SOURCES = aboutdialog.cpp associatedialog.cpp binaryfile.cpp \
+ xmlcopyeditor_SOURCES = aboutdialog.cpp \
diff --git a/editors/xmlcopyeditor/files/patch-src_myipc.cpp b/editors/xmlcopyeditor/files/patch-src_myipc.cpp
deleted file mode 100644
index 455ed07d28ee..000000000000
--- a/editors/xmlcopyeditor/files/patch-src_myipc.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/myipc.cpp.orig 2017-09-04 09:59:48 UTC
-+++ src/myipc.cpp
-@@ -46,7 +46,7 @@ wxConnectionBase *MyServer::OnAcceptConn
-
- MyServerConnection::MyServerConnection()
- : wxConnection()
-- , mFrameWnd ( ( wxIntPtr ) NULL )
-+ , mFrameWnd (0)
- {
- server_connection = this;
- }
diff --git a/editors/xmlcopyeditor/pkg-plist b/editors/xmlcopyeditor/pkg-plist
index c18694cae935..861a85284f7d 100644
--- a/editors/xmlcopyeditor/pkg-plist
+++ b/editors/xmlcopyeditor/pkg-plist
@@ -1,21 +1,7 @@
bin/xmlcopyeditor
man/man1/xmlcopyeditor.1.gz
-share/appdata/xmlcopyeditor.appdata.xml
share/applications/xmlcopyeditor.desktop
-share/locale/ca/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/de/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/en_US/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/es/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/fr/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/it/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/km/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/nl/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/ru/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/sk/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/sv/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/uk_UA/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/zh_CN/LC_MESSAGES/xmlcopyeditor.mo
-share/locale/zh_TW/LC_MESSAGES/xmlcopyeditor.mo
+share/metainfo/xmlcopyeditor.appdata.xml
share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/catalog/catalog
%%DATADIR%%/dtd/NewsML_1.2.dtd