aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-06-05 08:31:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-06-05 08:32:00 +0000
commit3f7756e2eaa2440f421cf93adfd75eac8de02358 (patch)
treed708e435df9223bdd8f29a3850d619a16d0ceb6d
parentb16826dfb4c0a355c86768c8d3dbbce19d9518db (diff)
downloadports-3f7756e2eaa2440f421cf93adfd75eac8de02358.tar.gz
ports-3f7756e2eaa2440f421cf93adfd75eac8de02358.zip
misc/rgb-tui: New port: Create and get color codes from the terminal using a nice interface
-rw-r--r--misc/Makefile1
-rw-r--r--misc/rgb-tui/Makefile25
-rw-r--r--misc/rgb-tui/distinfo3
-rw-r--r--misc/rgb-tui/files/patch-CMakeLists.txt22
-rw-r--r--misc/rgb-tui/pkg-descr1
5 files changed, 52 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a6b24afe27e7..448561e32c74 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -543,6 +543,7 @@
SUBDIR += ree
SUBDIR += retry
SUBDIR += rfc
+ SUBDIR += rgb-tui
SUBDIR += ringtonetools
SUBDIR += rname
SUBDIR += rpl
diff --git a/misc/rgb-tui/Makefile b/misc/rgb-tui/Makefile
new file mode 100644
index 000000000000..f36702cd3728
--- /dev/null
+++ b/misc/rgb-tui/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= rgb-tui
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1-6
+DISTVERSIONSUFFIX= -g207f0d9
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Create and get color codes from the terminal using a nice interface
+WWW= https://github.com/ArthurSonzogni/rgb-tui
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libclip.so:x11/clip \
+ libfmt.so:devel/libfmt \
+ libftxui-screen.so:devel/ftxui
+
+USES= cmake localbase:ldflags
+
+USE_GITHUB= yes
+GH_ACCOUNT= ArthurSonzogni
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/misc/rgb-tui/distinfo b/misc/rgb-tui/distinfo
new file mode 100644
index 000000000000..a8d904ea4eaf
--- /dev/null
+++ b/misc/rgb-tui/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1717555847
+SHA256 (ArthurSonzogni-rgb-tui-v1.1-6-g207f0d9_GH0.tar.gz) = 57d90a67fddf822e78bf24849b30a9dad0e66f7ff788cd1a83eedcc300204c1b
+SIZE (ArthurSonzogni-rgb-tui-v1.1-6-g207f0d9_GH0.tar.gz) = 16785409
diff --git a/misc/rgb-tui/files/patch-CMakeLists.txt b/misc/rgb-tui/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a51ca354c1fb
--- /dev/null
+++ b/misc/rgb-tui/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2024-06-02 14:31:17 UTC
++++ CMakeLists.txt
+@@ -9,6 +9,7 @@ set(BUILD_SHARED_LIBS FALSE)
+ set(BUILD_SHARED_LIBS FALSE)
+
+ # --- Fetch FTXUI --------------------------------------------------------------
++if (FALSE)
+ include(FetchContent)
+
+ set(FETCHCONTENT_UPDATES_DISCONNECTED TRUE)
+@@ -45,6 +46,11 @@ endif()
+ add_subdirectory(${clip_SOURCE_DIR} ${clip_BINARY_DIR} EXCLUDE_FROM_ALL)
+ target_include_directories(clip INTERFACE ${clip_SOURCE_DIR})
+ endif()
++
++endif()
++
++find_package(ftxui)
++find_package(fmt)
+
+ # ------------------------------------------------------------------------------
+
diff --git a/misc/rgb-tui/pkg-descr b/misc/rgb-tui/pkg-descr
new file mode 100644
index 000000000000..1bf5a47a90d4
--- /dev/null
+++ b/misc/rgb-tui/pkg-descr
@@ -0,0 +1 @@
+rgb-tui is a color picker with a terminal UI.