aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-02-03 00:56:59 +0000
committerWen Heping <wen@FreeBSD.org>2024-02-03 00:58:29 +0000
commit3f853a69d83c9929a7c7eb9f5ad3425936e0c9da (patch)
tree99d0231f09a63f4fb23593c030366e6bc4c08bd5
parentca41103d32ee6a8fb8f1fdc644032c0743944f49 (diff)
downloadports-3f853a69d83c9929a7c7eb9f5ad3425936e0c9da.tar.gz
ports-3f853a69d83c9929a7c7eb9f5ad3425936e0c9da.zip
biology/python-nexus: Update to 2.9.0 and fix build with python-3.11
PR: 275494
-rw-r--r--biology/python-nexus/Makefile9
-rw-r--r--biology/python-nexus/distinfo6
-rw-r--r--biology/python-nexus/files/patch-2to319
3 files changed, 9 insertions, 25 deletions
diff --git a/biology/python-nexus/Makefile b/biology/python-nexus/Makefile
index f4c08ebdbb7f..06f7e0c6a6c4 100644
--- a/biology/python-nexus/Makefile
+++ b/biology/python-nexus/Makefile
@@ -1,5 +1,5 @@
PORTNAME= python-nexus
-PORTVERSION= 1.63
+PORTVERSION= 2.9.0
CATEGORIES= biology python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +11,11 @@ WWW= http://simon.net.nz/articles/python-nexus
LICENSE= BSD3CLAUSE
#LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python shebangfix
-SHEBANG_FILES= nexus/bin/*.py
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}clldutils>=0:devel/py-clldutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}termcolor>=0:devel/py-termcolor@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}newick>=0:biology/py-newick@${PY_FLAVOR}
+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/biology/python-nexus/distinfo b/biology/python-nexus/distinfo
index cd63640bc1f2..70ddcd274d66 100644
--- a/biology/python-nexus/distinfo
+++ b/biology/python-nexus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1537606240
-SHA256 (python-nexus-1.63.tar.gz) = 5c9f39bc08a8459078cc65e74f30402df133f8eb06d7acf2c7667e8761657312
-SIZE (python-nexus-1.63.tar.gz) = 37986
+TIMESTAMP = 1706882239
+SHA256 (python-nexus-2.9.0.tar.gz) = 9eea1a0e79dc20b84310a84d4cc90665b1a359a74c17cc0a7602e54156188204
+SIZE (python-nexus-2.9.0.tar.gz) = 34242
diff --git a/biology/python-nexus/files/patch-2to3 b/biology/python-nexus/files/patch-2to3
deleted file mode 100644
index 07cc1ef4371c..000000000000
--- a/biology/python-nexus/files/patch-2to3
+++ /dev/null
@@ -1,19 +0,0 @@
---- nexus/bin/nexuscheck.py.orig 2018-04-10 09:11:00 UTC
-+++ nexus/bin/nexuscheck.py
-@@ -1,6 +1,6 @@
- #!/usr/bin/env python
- import warnings
--from __future__ import print_function
-+
- from nexus import NexusReader, VERSION
- from nexus.checker import checkers
-
-@@ -44,7 +44,7 @@ if __name__ == '__main__':
- if len(warned):
- print("Warnings encountered in reading nexus:")
- for w in warned:
-- print("\t%s" % w)
-+ print(("\t%s" % w))
-
- for checker in checkers:
- checker(nex, verbose=args.verbose).status()