aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-10-25 10:45:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-10-25 10:45:20 +0000
commit3fb819409bdc388fe69c98c43fd7de763e15f36d (patch)
treeb91aa28ac355068173913bb67e27dd8ef45d2f3e
parent5fd1759d2a4e031d77db7504c718eb7c8d69de4c (diff)
downloadports-3fb819409bdc388fe69c98c43fd7de763e15f36d.tar.gz
ports-3fb819409bdc388fe69c98c43fd7de763e15f36d.zip
Mk/bsd.wx.mk: allow to specify preferred GTK+ for wxWidgets 3.0.
-rw-r--r--Mk/bsd.wx.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index bd6bc9b1c6d8..e3729cd0d744 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -57,6 +57,8 @@
# overridden by the user variable WITH_WX_VER if set. It can
# contain multiple versions in order of preference (last ones
# are tried first).
+# WANT_WXGTK_VER - Set to the preferred GTK+ version, "2" or "3", "3" being
+# the default (only applicable to wxWidgets 3.0 for now).
#
# The following variables are intended for the user and can be defined in
# make.conf.
@@ -132,7 +134,7 @@ _WX_PORT_contrib_2.8= x11-toolkits/wxgtk28-contrib
_WX_LIB_contrib_2.8= wx_gtk2${_WX_UC}_fl-2.8
# wxgtk 3.0
-_WX_PORT_wx_3.0= x11-toolkits/wxgtk30
+_WX_PORT_wx_3.0= x11-toolkits/wxgtk30@${_GTKFLAVOR}
_WX_LIB_wx_3.0= wx_baseu-3.0
_WX_PORT_python_3.0= x11-toolkits/py-wxPython40@${PY_FLAVOR}
@@ -405,8 +407,11 @@ _WX_VER= ${ver}
# Set variables.
#
-.if ${_WX_VER:R} == 3
+.if ${_WX_VER} == 3.1
_GTKVER= 3
+.elif ${_WX_VER} == 3.0
+_GTKVER= ${WANT_WXGTK_VER:U3}
+_GTKFLAVOR= gtk${_GTKVER}
.else
_GTKVER= 2
.endif