aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2021-12-21 16:49:39 +0000
committerLewis Cook <lcook@FreeBSD.org>2021-12-21 16:54:57 +0000
commit40131f2c50e4af829e15c6a2aca0d07445bea2b0 (patch)
treef9795a50ecf2d523d69943e9672c2bbcf640df24
parent961004fa4c318ba138df06fa77311cab40e8d4be (diff)
downloadports-40131f2c50e4af829e15c6a2aca0d07445bea2b0.tar.gz
ports-40131f2c50e4af829e15c6a2aca0d07445bea2b0.zip
sysutils/py-concurrent-log-handler: Add new port
PR: 256268
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-concurrent-log-handler/Makefile18
-rw-r--r--sysutils/py-concurrent-log-handler/distinfo3
-rw-r--r--sysutils/py-concurrent-log-handler/pkg-descr11
4 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 391750bd7490..b9adca679046 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1023,6 +1023,7 @@
SUBDIR += py-azure-cli-telemetry
SUBDIR += py-bitrot
SUBDIR += py-borgmatic
+ SUBDIR += py-concurrent-log-handler
SUBDIR += py-cron-descriptor
SUBDIR += py-croniter
SUBDIR += py-dict-toolbox
diff --git a/sysutils/py-concurrent-log-handler/Makefile b/sysutils/py-concurrent-log-handler/Makefile
new file mode 100644
index 000000000000..9fdc9e43e2cf
--- /dev/null
+++ b/sysutils/py-concurrent-log-handler/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= concurrent-log-handler
+DISTVERSION= 0.9.19
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= risner@stdio.com
+COMMENT= RotatingFileHandler replacement with concurrency, gzip
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}portalocker>=1.4.0:devel/py-portalocker@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-concurrent-log-handler/distinfo b/sysutils/py-concurrent-log-handler/distinfo
new file mode 100644
index 000000000000..5b05a5d9b4c0
--- /dev/null
+++ b/sysutils/py-concurrent-log-handler/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622378074
+SHA256 (concurrent-log-handler-0.9.19.tar.gz) = b12f79abed3f94121c25ce9c24cdb57d889282ec6ff61f5535ab2068dc37d409
+SIZE (concurrent-log-handler-0.9.19.tar.gz) = 20780
diff --git a/sysutils/py-concurrent-log-handler/pkg-descr b/sysutils/py-concurrent-log-handler/pkg-descr
new file mode 100644
index 000000000000..6343eaa48859
--- /dev/null
+++ b/sysutils/py-concurrent-log-handler/pkg-descr
@@ -0,0 +1,11 @@
+This package provides an additional log handler for Python's standard logging
+package (PEP 282). This handler will write log events to a log file which is
+rotated when the log file reaches a certain size. Multiple processes can
+safely write to the same log file concurrently. Rotated logs can be gzipped
+if desired. Both Windows and POSIX systems are supported. An optional threaded
+queue logging handler is provided to perform logging in the background.
+
+This is a fork of Lowell Alleman's ConcurrentLogHandler 0.9.1 which fixes
+a hanging/deadlocking problem.
+
+WWW: https://pypi.org/project/concurrent-log-handler/