aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-09-15 11:03:25 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-09-15 11:03:25 +0000
commit4018c2022be41e2e634d970655cfe78c4b997dc0 (patch)
treeef852b00b73f709fde835d9f5cd55f58036e36f1
parentd45ea8db947ff569f2eba233d2c7179dc2189df0 (diff)
downloadports-4018c2022be41e2e634d970655cfe78c4b997dc0.tar.gz
ports-4018c2022be41e2e634d970655cfe78c4b997dc0.zip
deskutils/xfce4-notifyd: Properly handle libcanberra dependency
xfce4-notifyd configure script automatically adds a dependency on libcanberra-gtk3 if found on the system. To have control on this I added a new CANBERRA option (disabled by default) to the port to control configure behavior and ensure that the port does not link to it if the option is disabled. PR: 273805 MFH: 2023Q3
-rw-r--r--deskutils/xfce4-notifyd/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index 5357a2e2d4a0..a4403cbf81c4 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -5,7 +5,7 @@
PORTNAME= xfce4-notifyd
PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE/apps
DIST_SUBDIR= xfce4
@@ -29,9 +29,15 @@ USE_XORG= ice sm x11
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= CANBERRA NLS
OPTIONS_SUB= yes
+CANBERRA_DESC= Sound (audio) support via canberra
+
+CANBERRA_LIB_DEPENDS= libcanberra.so:audio/libcanberra \
+ libcanberra-gtk3.so:audio/libcanberra-gtk3
+CANBERRA_CONFIGURE_ENABLE= canberra
+
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls