aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 20:12:51 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 20:12:51 +0000
commit403b59e691135b14f952c6e3759a41dc07cfc1b4 (patch)
treedd6d9061245205765de162ec9bb778a46c69e8ac
parent5f369cb4b991964caee14c0474a99e9b9a091752 (diff)
downloadports-403b59e691135b14f952c6e3759a41dc07cfc1b4.tar.gz
ports-403b59e691135b14f952c6e3759a41dc07cfc1b4.zip
devel/py-resolvelib1: Add py-resolvelib1 1.0.1
ResolveLib at the highest level provides a Resolver class that includes dependency resolution logic. You give it some things, and a little information on how it should interact with them, and it will spit out a resolution result.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-resolvelib1/Makefile26
-rw-r--r--devel/py-resolvelib1/distinfo3
-rw-r--r--devel/py-resolvelib1/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 39dc8e47ce64..c40f9ebe2bd3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5400,6 +5400,7 @@
SUBDIR += py-resolvelib
SUBDIR += py-resolvelib05
SUBDIR += py-resolvelib07
+ SUBDIR += py-resolvelib1
SUBDIR += py-resolver
SUBDIR += py-resource
SUBDIR += py-responses
diff --git a/devel/py-resolvelib1/Makefile b/devel/py-resolvelib1/Makefile
new file mode 100644
index 000000000000..754e8b20f7f4
--- /dev/null
+++ b/devel/py-resolvelib1/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= resolvelib
+DISTVERSION= 1.0.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Resolve abstract dependencies into concrete ones
+WWW= https://github.com/sarugaku/resolvelib
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=36.2.2:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.28.0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}resolvelib \
+ ${PYTHON_PKGNAMEPREFIX}resolvelib0[0-9]
+
+.include <bsd.port.mk>
diff --git a/devel/py-resolvelib1/distinfo b/devel/py-resolvelib1/distinfo
new file mode 100644
index 000000000000..30d50f2ce340
--- /dev/null
+++ b/devel/py-resolvelib1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681586892
+SHA256 (resolvelib-1.0.1.tar.gz) = 04ce76cbd63fded2078ce224785da6ecd42b9564b1390793f64ddecbe997b309
+SIZE (resolvelib-1.0.1.tar.gz) = 21065
diff --git a/devel/py-resolvelib1/pkg-descr b/devel/py-resolvelib1/pkg-descr
new file mode 100644
index 000000000000..da0cad373e8e
--- /dev/null
+++ b/devel/py-resolvelib1/pkg-descr
@@ -0,0 +1,3 @@
+ResolveLib at the highest level provides a Resolver class that includes
+dependency resolution logic. You give it some things, and a little information
+on how it should interact with them, and it will spit out a resolution result.