aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2024-03-11 19:31:11 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2024-03-11 19:32:08 +0000
commit404309f7d10292d119753099131ae7c155e05a25 (patch)
treedc60891dd33787ab99eddadcc85e42046f523e4f
parent3af26eeeb335e796f7563d386a498207f81145b9 (diff)
downloadports-404309f7d10292d119753099131ae7c155e05a25.tar.gz
ports-404309f7d10292d119753099131ae7c155e05a25.zip
science/getdp: Updat to 3.6.0.
Also include patch that maintainer will push upstream.
-rw-r--r--science/getdp/Makefile3
-rw-r--r--science/getdp/distinfo6
-rw-r--r--science/getdp/files/patch-src_kernel_LinAlg__SPARSKIT.cpp11
3 files changed, 15 insertions, 5 deletions
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index 17ce626ea0e4..ea2ab883a61d 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -1,6 +1,5 @@
PORTNAME= getdp
-PORTVERSION= 3.5.0
-PORTREVISION= 2
+PORTVERSION= 3.6.0
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
diff --git a/science/getdp/distinfo b/science/getdp/distinfo
index 4f4d49029d3f..21133c0a3622 100644
--- a/science/getdp/distinfo
+++ b/science/getdp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1652456807
-SHA256 (getdp-3.5.0-source.tgz) = 0bf76c49efa9b88401a457c12f7aabd97597ad49ef632d3fb9308aa8ea437bdc
-SIZE (getdp-3.5.0-source.tgz) = 1901571
+TIMESTAMP = 1709878592
+SHA256 (getdp-3.6.0-source.tgz) = 37571bef65bbec3afe4f3787a4b82fe45b856fe489ab219c7e7fa439f12f6600
+SIZE (getdp-3.6.0-source.tgz) = 1900780
diff --git a/science/getdp/files/patch-src_kernel_LinAlg__SPARSKIT.cpp b/science/getdp/files/patch-src_kernel_LinAlg__SPARSKIT.cpp
new file mode 100644
index 000000000000..cf21fca26281
--- /dev/null
+++ b/science/getdp/files/patch-src_kernel_LinAlg__SPARSKIT.cpp
@@ -0,0 +1,11 @@
+--- src/kernel/LinAlg_SPARSKIT.cpp.orig 2024-03-08 06:48:58 UTC
++++ src/kernel/LinAlg_SPARSKIT.cpp
+@@ -117,7 +117,7 @@ void LinAlg_CreateVector(gVector *V, gSolver *Solver,
+ V->N = n;
+ }
+
+-void LinAlg_CreateMatrix(gMatrix *M, gSolver *Solver, int n, int m)
++void LinAlg_CreateMatrix(gMatrix *M, gSolver *Solver, int n, int m, bool silent)
+ {
+ init_matrix(n, &M->M, &Solver->Params);
+ }