aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-12-08 10:24:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-12-08 10:24:32 +0000
commit406c1bd11b50161ab3ed5ab46a79529fc6e89bfb (patch)
treebe5ba5de24fe1637fcd91d95a2bc0b56ca4613f6
parent201f20199f7c8c76483526cd09b50176f6dc02f2 (diff)
downloadports-406c1bd11b50161ab3ed5ab46a79529fc6e89bfb.tar.gz
ports-406c1bd11b50161ab3ed5ab46a79529fc6e89bfb.zip
net/spiritvnc: the port had been updated to version 0.5.4
This brings new features, bug fixes, and tons of improvements; one big change is a switch from using libssh2 to the system's built-in ssh(1) program. Reported by: Will Brokenbourgh (upstream developer)
-rw-r--r--net/spiritvnc/Makefile9
-rw-r--r--net/spiritvnc/distinfo6
-rw-r--r--net/spiritvnc/files/patch-Makefile28
3 files changed, 24 insertions, 19 deletions
diff --git a/net/spiritvnc/Makefile b/net/spiritvnc/Makefile
index de536c81cc31..679484e999ef 100644
--- a/net/spiritvnc/Makefile
+++ b/net/spiritvnc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= spiritvnc
-PORTVERSION= 0.4.6
-PORTREVISION= 1
+PORTVERSION= 0.5.4
+DISTVERSIONPREFIX= v
CATEGORIES= net
MAINTAINER= danfe@FreeBSD.org
@@ -13,15 +13,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png \
- libssh2.so:security/libssh2 \
libvncclient.so:net/libvncserver
-USES= jpeg pkgconfig xorg
+USES= gmake jpeg pkgconfig xorg
USE_GITHUB= yes
USE_XORG= x11 xcursor xext xfixes xft xinerama xpm xrender
GH_ACCOUNT= willbprog127
-GH_PROJECT= ${PORTNAME}-fltk
+GH_PROJECT= ${PORTNAME}-fltk-no-libssh2
PLIST_FILES= bin/${PORTNAME}
diff --git a/net/spiritvnc/distinfo b/net/spiritvnc/distinfo
index 4167665cf90c..6b25e2d64423 100644
--- a/net/spiritvnc/distinfo
+++ b/net/spiritvnc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621292146
-SHA256 (willbprog127-spiritvnc-fltk-0.4.6_GH0.tar.gz) = 539c03a9f2c516efba6d6d338eacc43e827c3775778cb0e1fa2e5a9a8a11cca9
-SIZE (willbprog127-spiritvnc-fltk-0.4.6_GH0.tar.gz) = 52118
+TIMESTAMP = 1698944824
+SHA256 (willbprog127-spiritvnc-fltk-no-libssh2-v0.5.4_GH0.tar.gz) = 78a8b43fe2338ac3e3a4fe32e45526c7ac0e8190951230ac8cd6b4cc5f680819
+SIZE (willbprog127-spiritvnc-fltk-no-libssh2-v0.5.4_GH0.tar.gz) = 56197
diff --git a/net/spiritvnc/files/patch-Makefile b/net/spiritvnc/files/patch-Makefile
index 577e48df3ca3..bdad63d5a40d 100644
--- a/net/spiritvnc/files/patch-Makefile
+++ b/net/spiritvnc/files/patch-Makefile
@@ -1,22 +1,28 @@
---- Makefile.orig 2021-02-15 06:05:31 UTC
+--- Makefile.orig 2023-11-02 17:07:04 UTC
+++ Makefile
-@@ -1,5 +1,5 @@
+@@ -1,10 +1,10 @@
CC = c++
--CFLAGS = -O2 -Wall -lpthread `fltk-config --use-images --cxxflags --ldflags` \
-+CFLAGS += -Wall -lpthread -lXpm `fltk-config --use-images --cxxflags --ldflags` \
- `pkg-config --cflags --libs libvncclient libvncserver libssh2`
+-CFLAGS = -O2 -Wall -Wunused -lpthread `fltk-config --use-images --cxxflags --ldflags` \
++CFLAGS += -Wall -Wunused -lpthread `fltk-config --use-images --cxxflags --ldflags` \
+ --std=c++11 -finline-functions
DEBUGFLGS= -g -O0
BINDIR = /usr/local/bin
-@@ -7,6 +7,8 @@ TARGET = spiritvnc-fltk
- SRC = `ls src/*.cxx`
+ TARGET = spiritvnc-fltk
+-SRC = `ls src/*.cxx`
++SRC = $(wildcard src/*.cxx)
PKGCONF = `which pkg-config`
+ LIBVNC =
+ OSNAME = $(shell uname -s)
+@@ -17,6 +17,8 @@ else
+ LIBVNC = `pkg-config --cflags --libs libvncclient libvncserver`
+ endif
+all: spiritvnc-fltk
+
spiritvnc-fltk:
- @if [ -z ${PKGCONF} ]; then \
- echo " " ; \
-@@ -30,7 +32,7 @@ clean::
+ @echo "Building on '$(OSNAME)'"
+ @echo ""
+@@ -47,7 +49,7 @@ clean::
rm -f $(TARGET)
install:
@@ -24,4 +30,4 @@
+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(DESTDIR)$(BINDIR)/spiritvnc
uninstall:
- @if [ -f ${BINDIR}"/"${TARGET} ] ; then \
+ @if [ -f $(BINDIR)"/"$(TARGET) ] ; then \