aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-02-10 14:35:46 +0000
committerCy Schubert <cy@FreeBSD.org>2023-02-10 14:40:47 +0000
commit40c294fd4f875a424d08c65bbb0dccb89a5e6e88 (patch)
tree0584d303be4c5fe1d29d3338a36a9f48a9a6c342
parentb3690ff9ffe8bfaa0460e888d5cbb0a1ea47f397 (diff)
downloadports-40c294fd4f875a424d08c65bbb0dccb89a5e6e88.tar.gz
ports-40c294fd4f875a424d08c65bbb0dccb89a5e6e88.zip
shells/ksh: Fix build with LLVM15
-rw-r--r--shells/ksh/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/shells/ksh/Makefile b/shells/ksh/Makefile
index ca0d38165128..e006024685ed 100644
--- a/shells/ksh/Makefile
+++ b/shells/ksh/Makefile
@@ -44,7 +44,7 @@ KSH93N_DESC= Install to ${PREFIX}/bin/ksh93n (new)
CFLAGS+= -DMAP_TYPE
LDFLAGS+= -lm
-MAKE_ENV= CCFLAGS="-Wno-unused-value -Wno-parentheses -Wno-logical-op-parentheses" CFLAGS="${CFLAGS}"
+MAKE_ENV= CCFLAGS="-Wno-unused-value -Wno-parentheses -Wno-logical-op-parentheses -Wno-int-conversion" CFLAGS="${CFLAGS}"
STATIC_MAKE_ENV= LDFLAGS+=-static