aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-12-02 23:09:03 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-12-02 23:09:03 +0000
commit40eb0c4f9753d898422c4aa8d7882710be966f13 (patch)
tree29c8def213118b8952ed1c7248407a52ded99db7
parent36708f6c380119889cf9422fd1001e0df8816e9e (diff)
downloadports-40eb0c4f9753d898422c4aa8d7882710be966f13.tar.gz
ports-40eb0c4f9753d898422c4aa8d7882710be966f13.zip
x11-themes/xfce-icons-elementary: Respect PREFIX, CFLAGS
- Make the port PREFIX safe by correctly passing the prefix argument to its configure script - Make the port respect CFLAGS when building an internal (not installed with the pkg) binary tool - Make REINPLACE_CMD silent PR: 275487
-rw-r--r--x11-themes/xfce-icons-elementary/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11-themes/xfce-icons-elementary/Makefile b/x11-themes/xfce-icons-elementary/Makefile
index 7ffdbb9a8ac1..29ebbddb6887 100644
--- a/x11-themes/xfce-icons-elementary/Makefile
+++ b/x11-themes/xfce-icons-elementary/Makefile
@@ -16,6 +16,7 @@ USES= compiler:c11 gnome pkgconfig
USE_GNOME= gdkpixbuf2:build gtk30:build
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix="${PREFIX}"
USE_GITHUB= yes
GH_ACCOUNT= shimmerproject
@@ -24,7 +25,7 @@ GH_PROJECT= elementary-xfce
NO_ARCH= yes
post-patch:
- ${REINPLACE_CMD} -e 's|\/$$(PREFIX)|$$(PREFIX)|g' \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-O0|${CFLAGS}|' \
+ ${WRKSRC}/svgtopng/Makefile
.include <bsd.port.mk>