aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-09-11 21:53:39 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-10-13 14:36:50 +0000
commit40fca1480b8a12b4faf6a36eca84c4ee6530c37f (patch)
treebf93891df951719c5ee3a8381d0049ffa86fcacd
parent1111994c240724ba85aefb2b7c1ed2ec9a315e86 (diff)
downloadports-40fca1480b8a12b4faf6a36eca84c4ee6530c37f.tar.gz
ports-40fca1480b8a12b4faf6a36eca84c4ee6530c37f.zip
games/freecell-solver: Unbreak on 32 bit platforms.
The port requires GMP on platforms that lack __int128, i.e. 32 bit platforms, but LIB_DEPENDS for libgmp is only present for i386. This patch extends the existing i386 special case to known 32 bit platforms so the port builds on armv7 FreeBSD and hopefully others. PR: 258442 Approved by: danilo (maintainer timeout) (cherry picked from commit cb25b8c9732d9bd51143dfcb533cd7e49fe05d88)
-rw-r--r--games/freecell-solver/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 69e32a071efa..de3c36306ad2 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -23,7 +23,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}random2>=1.0.1:math/py-random2@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pysol-cards>=0.10.0:games/py-pysol-cards@${PY_FLAVOR}
LIB_DEPENDS= ${LIB_DEPENDS_${ARCH}}
+LIB_DEPENDS_armv6= libgmp.so:math/gmp
+LIB_DEPENDS_armv7= libgmp.so:math/gmp
LIB_DEPENDS_i386= libgmp.so:math/gmp
+LIB_DEPENDS_mips= libgmp.so:math/gmp
+LIB_DEPENDS_powerpc= libgmp.so:math/gmp
OPTIONS_DEFINE= DOCS TCMALLOC
TCMALLOC_DESC= Use Google's TCMalloc