aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-01-20 09:11:16 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-01-22 00:59:39 +0000
commit41944891b2a0af2d90a9104712f07722937e5be4 (patch)
treed505514b372aefbd32286c2d1441ba89925c1d26
parentbb45ab8e09fc8ae7da6471fc845c1d7a76610213 (diff)
downloadports-41944891b2a0af2d90a9104712f07722937e5be4.tar.gz
ports-41944891b2a0af2d90a9104712f07722937e5be4.zip
emulators/yuzu: merge -qt5 port as QT5 option
yuzu package provided "yuzu-cmd" executable but it's very buggy and hard to use. yuzu-qt5 package provided stable "yuzu" executable. The split was inspired by citra{,-qt5} but in yuzu confused new users. (cherry picked from commit 57c6f7e1cbc6667455b50a022c9388e10ca83646)
-rw-r--r--MOVED1
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/yuzu-qt5/Makefile8
-rw-r--r--emulators/yuzu/Makefile14
-rw-r--r--emulators/yuzu/files/patch-CMakeLists.txt35
5 files changed, 5 insertions, 54 deletions
diff --git a/MOVED b/MOVED
index 22cdab471915..9ba71e670fb0 100644
--- a/MOVED
+++ b/MOVED
@@ -16759,3 +16759,4 @@ www/py-dj31-djangorestframework||2021-12-31|Has expired: Extended support of Dja
astro/google-earth||2022-01-01|Has expired: Needs newer version to connect to server
net/tramp||2022-01-01|Has expired: Not updated in 5 years and now part of Emacs
archivers/p7zip-codec-rar||2022-01-01|Has expired: Unmaintained for years and has known vulnerabilities
+emulators/yuzu-qt5|emulators/yuzu|2022-01-20|Merged as QT5 port option
diff --git a/emulators/Makefile b/emulators/Makefile
index a5926fd975fc..223ecc1d146f 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -179,7 +179,6 @@
SUBDIR += xzx
SUBDIR += yaze-ag
SUBDIR += yuzu
- SUBDIR += yuzu-qt5
SUBDIR += z80pack
SUBDIR += zsnes
diff --git a/emulators/yuzu-qt5/Makefile b/emulators/yuzu-qt5/Makefile
deleted file mode 100644
index 30c667b9c82a..000000000000
--- a/emulators/yuzu-qt5/Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
-PORTREVISION= 0
-PKGNAMESUFFIX= -qt5
-
-MASTERDIR= ${.CURDIR}/../yuzu
-
-OPTIONS_SLAVE= QT5
-
-.include "${MASTERDIR}/Makefile"
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 11ffd2cac856..3d6aaa5131b1 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,6 +1,6 @@
PORTNAME= yuzu
PORTVERSION= s20220119
-PORTREVISION?= 0
+PORTREVISION= 1
CATEGORIES= emulators
.if make(makesum)
MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb
@@ -67,13 +67,10 @@ CMAKE_OFF+= ${CMAKE_TESTING_ON}
CMAKE_TESTING_ON= YUZU_TESTS
LDFLAGS+= -static-libstdc++ # avoid libc++ conflict, requires files/patch-fmt
LDFLAGS+= -Wl,--as-needed # Qt5Network
+PLIST_FILES= bin/${PORTNAME}-cmd
-OPTIONS_DEFINE= ALSA PULSEAUDIO JACK SNDIO VAAPI VULKAN
-OPTIONS_DEFAULT=PULSEAUDIO JACK SNDIO VAAPI VULKAN
-OPTIONS_MULTI= GUI
-OPTIONS_MULTI_GUI= QT5 SDL
-OPTIONS_SLAVE?= SDL
-OPTIONS_EXCLUDE:= ${OPTIONS_MULTI_GUI}
+OPTIONS_DEFINE= ALSA PULSEAUDIO JACK QT5 SNDIO VAAPI VULKAN
+OPTIONS_DEFAULT=PULSEAUDIO JACK QT5 SNDIO VAAPI VULKAN
ALSA_BUILD_DEPENDS= alsa-lib>0:audio/alsa-lib
ALSA_CMAKE_BOOL= USE_ALSA
@@ -87,9 +84,6 @@ PULSEAUDIO_CMAKE_BOOL= USE_PULSE
SNDIO_BUILD_DEPENDS= sndio>0:audio/sndio
SNDIO_CMAKE_BOOL= USE_SNDIO
-SDL_CMAKE_BOOL= ENABLE_SDL2
-SDL_PLIST_FILES=bin/${PORTNAME}-cmd
-
QT5_USES= desktop-file-utils qt:5 shared-mime-info
QT5_USE= QT=qmake_build,buildtools_build,linguisttools_build,concurrent_build,core,gui,webengine,widgets
QT5_CMAKE_BOOL= ENABLE_QT ENABLE_QT_TRANSLATION YUZU_USE_QT_WEB_ENGINE
diff --git a/emulators/yuzu/files/patch-CMakeLists.txt b/emulators/yuzu/files/patch-CMakeLists.txt
deleted file mode 100644
index 43638c95a8bc..000000000000
--- a/emulators/yuzu/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,35 +0,0 @@
-yuzu (Qt) currently needs SDL for input
-
---- CMakeLists.txt.orig 2021-12-06 23:09:30 UTC
-+++ CMakeLists.txt
-@@ -395,7 +395,10 @@ if (ENABLE_SDL2)
- target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
- elseif (YUZU_USE_EXTERNAL_SDL2)
- message(STATUS "Using SDL2 from externals.")
-- else()
-+ endif()
-+endif()
-+
-+if (NOT YUZU_USE_BUNDLED_SDL2 AND NOT YUZU_USE_EXTERNAL_SDL2)
- find_package(SDL2 2.0.18 REQUIRED)
-
- # Some installations don't set SDL2_LIBRARIES
-@@ -407,7 +410,6 @@ if (ENABLE_SDL2)
- include_directories(SYSTEM ${SDL2_INCLUDE_DIRS})
- add_library(SDL2 INTERFACE)
- target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARIES}")
-- endif()
- endif()
-
- # Install any missing dependencies with conan install
---- src/input_common/CMakeLists.txt.orig 2021-04-21 21:36:33 UTC
-+++ src/input_common/CMakeLists.txt
-@@ -62,7 +62,7 @@ else()
- )
- endif()
-
--if (ENABLE_SDL2)
-+if (SDL2_FOUND)
- target_sources(input_common PRIVATE
- sdl/sdl_impl.cpp
- sdl/sdl_impl.h