aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-09-29 19:35:23 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-09-29 21:42:37 +0000
commit41d2f108ced1c38dc7acedcfca6b3cd902dfb5f7 (patch)
tree95a3261b0a23cda288b5014daa426b9f678ed56e
parent5a8bdd0faf7070b51a204911cac06b433388c1e6 (diff)
downloadports-41d2f108ced1c38dc7acedcfca6b3cd902dfb5f7.tar.gz
ports-41d2f108ced1c38dc7acedcfca6b3cd902dfb5f7.zip
devel/pyside6: Update after cb2e2b668ada
If comms/qt6-connectivity is installed, bindings are built for it.
-rw-r--r--devel/pyside6/Makefile3
-rw-r--r--devel/pyside6/pkg-plist8
2 files changed, 10 insertions, 1 deletions
diff --git a/devel/pyside6/Makefile b/devel/pyside6/Makefile
index 953c5516c23d..0f23ad4f0208 100644
--- a/devel/pyside6/Makefile
+++ b/devel/pyside6/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pyside6
DISTVERSION= ${PYSIDE6_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= QT/official_releases/QtForPython/shiboken6/PySide6-${DISTVERSION}-src
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +19,7 @@ USES= cmake gl llvm:lib python qt:6 tar:xz
USE_GL= gl
USE_LDCONFIG= yes
USE_PYTHON= flavors
-USE_QT= 3d base charts datavis3d declarative doc httpserver \
+USE_QT= 3d base charts connectivity datavis3d declarative doc httpserver \
imageformats location multimedia networkauth positioning \
quick3d quicktimeline remoteobjects scxml sensors serialbus \
serialport shadertools speech svg tools translations wayland \
diff --git a/devel/pyside6/pkg-plist b/devel/pyside6/pkg-plist
index 41440914c4ac..68f8126fb3c9 100644
--- a/devel/pyside6/pkg-plist
+++ b/devel/pyside6/pkg-plist
@@ -4,6 +4,7 @@ include/PySide6/Qt3DExtras/pyside6_qt3dextras_python.h
include/PySide6/Qt3DInput/pyside6_qt3dinput_python.h
include/PySide6/Qt3DLogic/pyside6_qt3dlogic_python.h
include/PySide6/Qt3DRender/pyside6_qt3drender_python.h
+include/PySide6/QtBluetooth/pyside6_qtbluetooth_python.h
include/PySide6/QtCharts/pyside6_qtcharts_python.h
include/PySide6/QtConcurrent/pyside6_qtconcurrent_python.h
include/PySide6/QtCore/pyside6_qtcore_python.h
@@ -24,6 +25,7 @@ include/PySide6/QtMultimedia/pyside6_qtmultimedia_python.h
include/PySide6/QtMultimediaWidgets/pyside6_qtmultimediawidgets_python.h
include/PySide6/QtNetwork/pyside6_qtnetwork_python.h
include/PySide6/QtNetworkAuth/pyside6_qtnetworkauth_python.h
+include/PySide6/QtNfc/pyside6_qtnfc_python.h
include/PySide6/QtOpenGL/pyside6_qtopengl_python.h
include/PySide6/QtOpenGLWidgets/pyside6_qtopenglwidgets_python.h
%%WEBENGINE%%include/PySide6/QtPdf/pyside6_qtpdf_python.h
@@ -130,6 +132,8 @@ lib/libpyside6qml.abi3.so.%%DISTVERSION%%
%%PYTHON_SITELIBDIR%%/PySide6/Qt3DLogic.pyi
%%PYTHON_SITELIBDIR%%/PySide6/Qt3DRender.abi3.so
%%PYTHON_SITELIBDIR%%/PySide6/Qt3DRender.pyi
+%%PYTHON_SITELIBDIR%%/PySide6/QtBluetooth.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtBluetooth.pyi
%%PYTHON_SITELIBDIR%%/PySide6/QtCharts.abi3.so
%%PYTHON_SITELIBDIR%%/PySide6/QtCharts.pyi
%%PYTHON_SITELIBDIR%%/PySide6/QtConcurrent.abi3.so
@@ -158,6 +162,8 @@ lib/libpyside6qml.abi3.so.%%DISTVERSION%%
%%PYTHON_SITELIBDIR%%/PySide6/QtNetwork.pyi
%%PYTHON_SITELIBDIR%%/PySide6/QtNetworkAuth.abi3.so
%%PYTHON_SITELIBDIR%%/PySide6/QtNetworkAuth.pyi
+%%PYTHON_SITELIBDIR%%/PySide6/QtNfc.abi3.so
+%%PYTHON_SITELIBDIR%%/PySide6/QtNfc.pyi
%%PYTHON_SITELIBDIR%%/PySide6/QtOpenGL.abi3.so
%%PYTHON_SITELIBDIR%%/PySide6/QtOpenGL.pyi
%%PYTHON_SITELIBDIR%%/PySide6/QtOpenGLWidgets.abi3.so
@@ -275,6 +281,7 @@ share/PySide6/typesystems/typesystem_3dextras.xml
share/PySide6/typesystems/typesystem_3dinput.xml
share/PySide6/typesystems/typesystem_3dlogic.xml
share/PySide6/typesystems/typesystem_3drender.xml
+share/PySide6/typesystems/typesystem_bluetooth.xml
share/PySide6/typesystems/typesystem_charts.xml
share/PySide6/typesystems/typesystem_concurrent.xml
share/PySide6/typesystems/typesystem_core.xml
@@ -299,6 +306,7 @@ share/PySide6/typesystems/typesystem_multimedia.xml
share/PySide6/typesystems/typesystem_multimediawidgets.xml
share/PySide6/typesystems/typesystem_network.xml
share/PySide6/typesystems/typesystem_networkauth.xml
+share/PySide6/typesystems/typesystem_nfc.xml
share/PySide6/typesystems/typesystem_opengl.xml
share/PySide6/typesystems/typesystem_opengl_modifications1_0.xml
share/PySide6/typesystems/typesystem_opengl_modifications1_0_compat.xml