aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-04-02 05:43:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-04-02 07:40:15 +0000
commit41ec3f1e05901263b88d240ac7791829015885ed (patch)
treece9a30105c51e00225f670cecb8fdf86831188cd
parentef9f1d648febc462d61e6b2848f79c2dd5ea4a12 (diff)
downloadports-41ec3f1e05901263b88d240ac7791829015885ed.tar.gz
ports-41ec3f1e05901263b88d240ac7791829015885ed.zip
science/spheral: Update 2022.6.1-680 → 2023.03.0
Reported by: portscout
-rw-r--r--science/spheral/Makefile8
-rw-r--r--science/spheral/distinfo6
-rw-r--r--science/spheral/pkg-plist27
3 files changed, 35 insertions, 6 deletions
diff --git a/science/spheral/Makefile b/science/spheral/Makefile
index d860baad3b6a..e25b709b89ea 100644
--- a/science/spheral/Makefile
+++ b/science/spheral/Makefile
@@ -1,7 +1,6 @@
PORTNAME= spheral
DISTVERSIONPREFIX= v
-DISTVERSION= 2022.6.1-680
-DISTVERSIONSUFFIX= -g23ce0f156
+DISTVERSION= 2023.03.0
CATEGORIES= science # physics
MAINTAINER= yuri@FreeBSD.org
@@ -16,12 +15,13 @@ LIB_DEPENDS= libaxom.so:science/axom \
libboost_filesystem.so:devel/boost-libs \
libconduit.so:science/conduit \
libhdf5.so:science/hdf5 \
+ libmfem.so:math/mfem \
libosdCPU.so:graphics/opensubdiv \
libpolytope.so:science/polytope \
libqhull_r.so:math/qhull \
libsiloh5.so:science/silo
-USES= cmake compiler:c++14-lang eigen:3 fortran mpi:mpich python
+USES= cmake:testing compiler:c++14-lang eigen:3 fortran lua mpi:mpich python
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -37,6 +37,7 @@ CMAKE_ARGS= -Daneos_DIR=${LOCALBASE} \
-Dhdf5_DIR=${LOCALBASE} \
-Dopensubdiv_DIR=${LOCALBASE} \
-Dpython_DIR=${LOCALBASE} \
+ -Dpolyclipper_DIR=${LOCALBASE} \
-Dpolytope_DIR=${LOCALBASE} \
-Dpybind11_DIR=${LOCALBASE} \
-Dqhull_DIR=${LOCALBASE} \
@@ -45,6 +46,7 @@ CMAKE_ARGS= -Daneos_DIR=${LOCALBASE} \
CMAKE_OFF= ENABLE_TESTS ENABLE_DOCS \
ENABLE_ANEOS
CMAKE_ON= ENABLE_CXXONLY # disable Python support which is still for Python-2.7, see https://github.com/LLNL/spheral/issues/183
+CMAKE_TESTING_ON= ENABLE_TESTS # tests fail to configure, see https://github.com/LLNL/spheral/issues/207
CXXFLAGS+= -I${LOCALBASE}/include/eigen3
diff --git a/science/spheral/distinfo b/science/spheral/distinfo
index 3575ce051e22..e9b1aa48c09a 100644
--- a/science/spheral/distinfo
+++ b/science/spheral/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1670638084
-SHA256 (LLNL-spheral-v2022.6.1-680-g23ce0f156_GH0.tar.gz) = 2287693db6e2b9c78cc8fc20b96e0b25571e660c371fec6f1cb2f14743629a82
-SIZE (LLNL-spheral-v2022.6.1-680-g23ce0f156_GH0.tar.gz) = 6529830
+TIMESTAMP = 1680247467
+SHA256 (LLNL-spheral-v2023.03.0_GH0.tar.gz) = 52544b9f031914a2b625d8f9ec822348e4b61076980a0029ac34c07ab459dc1c
+SIZE (LLNL-spheral-v2023.03.0_GH0.tar.gz) = 6639248
SHA256 (llnl-blt-ddd5a0c_GH0.tar.gz) = 5c235a9b160f1cc3f6ce4d7c80bf72772ac10839909f4f96075d08b3edd8f540
SIZE (llnl-blt-ddd5a0c_GH0.tar.gz) = 1220052
SHA256 (llnl-uberenv-126f8de_GH0.tar.gz) = 6a403e722dc023d87dd69f8235fa631ab96a7b1ff328929b9c969e7c113ce9f7
diff --git a/science/spheral/pkg-plist b/science/spheral/pkg-plist
index 31fb1c34a1dd..d389f57377c2 100644
--- a/science/spheral/pkg-plist
+++ b/science/spheral/pkg-plist
@@ -191,7 +191,9 @@ include/ExternalForce/PointPotential.hh
include/ExternalForce/PointPotentialInline.hh
include/FSISPH/FSIFieldNames.hh
include/FSISPH/SlideSurface.hh
+include/FSISPH/SlideSurfaceInline.hh
include/FSISPH/SolidFSISPHHydroBase.hh
+include/FSISPH/SolidFSISPHHydroBaseInline.hh
include/FSISPH/computeFSISPHSumMassDensity.hh
include/FSISPH/computeHWeightedFSISPHSumMassDensity.hh
include/Field/AggregateField.hh
@@ -340,6 +342,8 @@ include/Gravity/ApproximatePolyhedralGravityModel.hh
include/Gravity/ApproximatePolyhedralGravityModelInline.hh
include/Gravity/CompatibleGravitationalVelocityPolicy.hh
include/Gravity/NBodyGravity.hh
+include/Gravity/PolyGravity.hh
+include/Gravity/Tree.hh
include/Gravity/TreeGravity.hh
include/Gravity/TreeGravityInline.hh
include/Hydro/CompatibleDifferenceSpecificThermalEnergyPolicy.hh
@@ -414,6 +418,26 @@ include/Kernel/WendlandC4Kernel.hh
include/Kernel/WendlandC4KernelInline.hh
include/Kernel/WendlandC6Kernel.hh
include/Kernel/WendlandC6KernelInline.hh
+include/KernelIntegrator/BilinearIndex.hh
+include/KernelIntegrator/BilinearIndexInline.hh
+include/KernelIntegrator/DataTypeFunctions.hh
+include/KernelIntegrator/FlatConnectivity.hh
+include/KernelIntegrator/FlatConnectivityInline.hh
+include/KernelIntegrator/GaussLegendreValues.hh
+include/KernelIntegrator/IntegrationCoefficient.hh
+include/KernelIntegrator/IntegrationCoefficientInline.hh
+include/KernelIntegrator/IntegrationKernel.hh
+include/KernelIntegrator/KernelIntegral.hh
+include/KernelIntegrator/KernelIntegralInline.hh
+include/KernelIntegrator/KernelIntegrationData.hh
+include/KernelIntegrator/KernelIntegrator.hh
+include/KernelIntegrator/KernelIntegratorInline.hh
+include/KernelIntegrator/ManufacturedSolution.hh
+include/KernelIntegrator/RKIntegrationKernel.hh
+include/KernelIntegrator/RKIntegrationKernelInline.hh
+include/KernelIntegrator/SPHIntegrationKernel.hh
+include/KernelIntegrator/SymmetricTetrahedralValues.hh
+include/KernelIntegrator/SymmetricTriangularValues.hh
include/Material/EquationOfState.hh
include/Material/EquationOfStateInline.hh
include/Material/GammaLawGas.hh
@@ -476,6 +500,7 @@ include/NodeList/NodeListRegistrar.hh
include/NodeList/NodeListRegistrarInline.hh
include/NodeList/SPHSmoothingScale.hh
include/NodeList/SmoothingScaleBase.hh
+include/NodeList/SmoothingScaleBaseInline.hh
include/NodeList/SolidNodeList.hh
include/NodeList/SolidNodeListInline.hh
include/NodeList/generateVoidNodes.hh
@@ -557,6 +582,7 @@ include/SolidMaterial/NullStrength.hh
include/SolidMaterial/OsborneEquationOfState.hh
include/SolidMaterial/OsborneEquationOfStateInline.hh
include/SolidMaterial/PhysicsEvolvingMaterialLibrary.hh
+include/SolidMaterial/PiecewiseLinearPorousStrengthModel.hh
include/SolidMaterial/PolynomialFit.hh
include/SolidMaterial/PolynomialFitInline.hh
include/SolidMaterial/PorousEquationOfState.hh
@@ -668,6 +694,7 @@ include/Utilities/rotationMatrix.hh
include/Utilities/safeInv.hh
include/Utilities/scan.hh
include/Utilities/segmentIntersectEdges.hh
+include/Utilities/setGlobalFlags.hh
include/Utilities/simpsonsIntegration.hh
include/Utilities/size_t_bits.hh
include/Utilities/sort_permutation.hh