aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2023-07-18 12:53:17 +0000
committerRenato Botelho <garga@FreeBSD.org>2023-07-18 12:55:27 +0000
commit41f2281cb356debadcea7cd0ad994cf38730bf8b (patch)
treecc88f72a354e1fa994d38445247969164ddac957
parenta68c1f6ccab8140d1190a6d29d774672a5602d34 (diff)
downloadports-41f2281cb356debadcea7cd0ad994cf38730bf8b.tar.gz
ports-41f2281cb356debadcea7cd0ad994cf38730bf8b.zip
multimedia/gmmlib: Update to 22.3.9
-rw-r--r--multimedia/gmmlib/Makefile3
-rw-r--r--multimedia/gmmlib/distinfo6
-rw-r--r--multimedia/gmmlib/files/patch-Source_GmmLib_GlobalInfo_GmmInfo.cpp20
-rw-r--r--multimedia/gmmlib/files/patch-Source_GmmLib_inc_External_Common_GmmInfo.h20
4 files changed, 44 insertions, 5 deletions
diff --git a/multimedia/gmmlib/Makefile b/multimedia/gmmlib/Makefile
index 32c0c1e7970b..d8265f318c4a 100644
--- a/multimedia/gmmlib/Makefile
+++ b/multimedia/gmmlib/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gmmlib
DISTVERSIONPREFIX= intel-${PORTNAME}-
-DISTVERSION= 22.3.6
+DISTVERSION= 22.3.9
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -8,7 +8,6 @@ PATCHFILES+= f17dd87c7f57.patch:-p1 # https://github.com/intel/gmmlib/pull/67
PATCHFILES+= 4356a33c787c.patch:-p1 # https://github.com/intel/gmmlib/pull/68
PATCHFILES+= a75809957583.patch:-p1 # https://github.com/intel/gmmlib/pull/68
PATCHFILES+= 978f7d56f88a.patch:-p1 # https://github.com/intel/gmmlib/pull/68
-PATCHFILES+= 9e844d7c052d.patch:-p1 # https://github.com/intel/gmmlib/pull/68
PATCHFILES+= 072810163a05.patch:-p1 # https://github.com/intel/gmmlib/pull/68
PATCHFILES+= ab150305017a.patch:-p1 # https://github.com/intel/gmmlib/pull/68
PATCHFILES+= 0d45ab8163e7.patch:-p1 # https://github.com/intel/gmmlib/pull/68
diff --git a/multimedia/gmmlib/distinfo b/multimedia/gmmlib/distinfo
index f9e110d2aaf9..ab197818e4c8 100644
--- a/multimedia/gmmlib/distinfo
+++ b/multimedia/gmmlib/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1686068750
-SHA256 (intel-gmmlib-intel-gmmlib-22.3.6_GH0.tar.gz) = be853a72be8cc0a9d34a8e1a80c97e8c655c548a9f3bdeba953186725d562839
-SIZE (intel-gmmlib-intel-gmmlib-22.3.6_GH0.tar.gz) = 843539
+TIMESTAMP = 1689680240
+SHA256 (intel-gmmlib-intel-gmmlib-22.3.9_GH0.tar.gz) = 62d2f8333f1da3361952546a83dd40d1eb23d8bddacf67a160e63f565b68b5a6
+SIZE (intel-gmmlib-intel-gmmlib-22.3.9_GH0.tar.gz) = 845228
SHA256 (f17dd87c7f57.patch) = 0bdfd22e8f36a097c875796c7bbf7003a16cc7535fdf5d3caa3a7de9dc21c28e
SIZE (f17dd87c7f57.patch) = 1485
SHA256 (4356a33c787c.patch) = bfcb39e72f470bc695a6c356bc0ad06c7ac6b8f0f4b64b41deb3d0678ec29171
diff --git a/multimedia/gmmlib/files/patch-Source_GmmLib_GlobalInfo_GmmInfo.cpp b/multimedia/gmmlib/files/patch-Source_GmmLib_GlobalInfo_GmmInfo.cpp
new file mode 100644
index 000000000000..45093ae4ae57
--- /dev/null
+++ b/multimedia/gmmlib/files/patch-Source_GmmLib_GlobalInfo_GmmInfo.cpp
@@ -0,0 +1,20 @@
+--- Source/GmmLib/GlobalInfo/GmmInfo.cpp.orig 2023-07-18 11:43:35 UTC
++++ Source/GmmLib/GlobalInfo/GmmInfo.cpp
+@@ -937,7 +937,7 @@ int32_t GmmLib::Context::IncrementRefCount()
+ {
+ int32_t *Ref = &RefCount;
+
+-#if defined(__linux__)
++#if defined(__GNUC__)
+ // returns 0 only when registering the first client
+ return (__sync_fetch_and_add(Ref, 1));
+ #endif
+@@ -972,7 +972,7 @@ int32_t GmmLib::Context::DecrementRefCount()
+ {
+ break;
+ }
+-#if defined(__linux__)
++#if defined(__GNUC__)
+ } while(!__sync_bool_compare_and_swap(Ref, CurrentValue, TargetValue));
+ #endif
+ return TargetValue;
diff --git a/multimedia/gmmlib/files/patch-Source_GmmLib_inc_External_Common_GmmInfo.h b/multimedia/gmmlib/files/patch-Source_GmmLib_inc_External_Common_GmmInfo.h
new file mode 100644
index 000000000000..c1df2d89eed4
--- /dev/null
+++ b/multimedia/gmmlib/files/patch-Source_GmmLib_inc_External_Common_GmmInfo.h
@@ -0,0 +1,20 @@
+--- Source/GmmLib/inc/External/Common/GmmInfo.h.orig 2023-07-18 11:42:34 UTC
++++ Source/GmmLib/inc/External/Common/GmmInfo.h
+@@ -141,7 +141,7 @@ namespace GmmLib
+ {
+ #if defined(_WIN32)
+ return(InterlockedIncrement((LONG *)&RefCount) - 1); //InterLockedIncrement() returns incremented value
+-#elif defined(__linux__)
++#elif defined(__GNUC__)
+ return(__sync_fetch_and_add(&RefCount, 1));
+ #endif
+ }
+@@ -163,7 +163,7 @@ namespace GmmLib
+ }
+ #if defined(_WIN32)
+ } while (!(InterlockedCompareExchange((LONG *)&RefCount, TargetValue, CurrentValue) == CurrentValue));
+-#elif defined(__linux__)
++#elif defined(__GNUC__)
+ } while (!__sync_bool_compare_and_swap(&RefCount, CurrentValue, TargetValue));
+ #endif
+