aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-06 00:00:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-06 00:00:00 +0000
commit4218c128a3376d7551694335e85ec9c64e596463 (patch)
treeb5796a8627205309df6e5c73ee6e500ed9aa036a
parent0368b764f2c45250550f062f9e5218d63072c06f (diff)
downloadports-4218c128a3376d7551694335e85ec9c64e596463.tar.gz
ports-4218c128a3376d7551694335e85ec9c64e596463.zip
www/py-django32: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--www/py-django32/Makefile5
-rw-r--r--www/py-django32/files/patch-setup.cfg9
2 files changed, 13 insertions, 1 deletions
diff --git a/www/py-django32/Makefile b/www/py-django32/Makefile
index 1b1a659ed1e9..d09c5c5f6f32 100644
--- a/www/py-django32/Makefile
+++ b/www/py-django32/Makefile
@@ -1,5 +1,6 @@
PORTNAME= django
PORTVERSION= 3.2.25
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI \
https://media.djangoproject.com/releases/${PORTVERSION:R}/
@@ -18,13 +19,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Django 3.2 is now in Extended Support, receives security fixes only and will reach End-Of-Life in April 2024. Upgrade to a later Django version. See https://www.djangoproject.com/download/
EXPIRATION_DATE=2024-06-30
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}asgiref>0:www/py-asgiref@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlparse>=0:databases/py-sqlparse@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tblib>0:devel/py-tblib@${PY_FLAVOR}
USES= cpe python shebangfix
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
NO_ARCH= yes
diff --git a/www/py-django32/files/patch-setup.cfg b/www/py-django32/files/patch-setup.cfg
new file mode 100644
index 000000000000..cf8a570a4bbf
--- /dev/null
+++ b/www/py-django32/files/patch-setup.cfg
@@ -0,0 +1,9 @@
+--- setup.cfg.orig 2024-03-04 07:49:27 UTC
++++ setup.cfg
+@@ -1,5 +1,5 @@
+ [metadata]
+-name = Django
++name = django
+ version = attr: django.__version__
+ url = https://www.djangoproject.com/
+ author = Django Software Foundation