aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2022-12-16 21:06:40 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-12-16 21:08:54 +0000
commit425a32db6a0406255991176098e93ba221218678 (patch)
tree152a26953b7ad35d8348697276742acd378ac307
parente770eab55618d876a445eb4e2dffc3fda20682f7 (diff)
downloadports-425a32db6a0406255991176098e93ba221218678.tar.gz
ports-425a32db6a0406255991176098e93ba221218678.zip
security/s2n-tls: Fix llvm15 build
Fix llvm15 build due to the port using -Werror by default, and prototypes are now more strictly checked. Add -Wno-strict-prototypes to CFLAGS to suppress the warnings-as-errors. PR: 268413
-rw-r--r--security/s2n-tls/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/s2n-tls/Makefile b/security/s2n-tls/Makefile
index 66d433df8bc2..fc8a98cdf166 100644
--- a/security/s2n-tls/Makefile
+++ b/security/s2n-tls/Makefile
@@ -1,6 +1,7 @@
PORTNAME= s2n-tls
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.31
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
@@ -20,6 +21,9 @@ USE_LDCONFIG= yes
CMAKE_OFF= BUILD_TESTING
CMAKE_ON= BUILD_SHARED_LIBS
+# Fix llvm15 build, PR 268413
+CFLAGS+= -Wno-strict-prototypes
+
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS EXAMPLES LTO