aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2023-12-02 02:45:03 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2023-12-02 02:46:23 +0000
commit426ebf500a27d3f0f7d4b18eae1e1e6d908bf7ec (patch)
treec8becdea56b3f8f2174f2ccec428b329c4e07ea6
parent6c4806b462e98ff76c087ca9ca81dfc96136061d (diff)
downloadports-426ebf500a27d3f0f7d4b18eae1e1e6d908bf7ec.tar.gz
ports-426ebf500a27d3f0f7d4b18eae1e1e6d908bf7ec.zip
comms/scrcpy: update to 2.3
Changelog: https://github.com/Genymobile/scrcpy/releases/tag/v2.3 Reported by: GitHub (watch releases)
-rw-r--r--comms/scrcpy/Makefile2
-rw-r--r--comms/scrcpy/distinfo10
-rw-r--r--comms/scrcpy/files/patch-app_meson.build6
-rw-r--r--comms/scrcpy/files/patch-app_src_cli.c19
4 files changed, 28 insertions, 9 deletions
diff --git a/comms/scrcpy/Makefile b/comms/scrcpy/Makefile
index a054673cbae0..a4d8e768cd8b 100644
--- a/comms/scrcpy/Makefile
+++ b/comms/scrcpy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= scrcpy
DISTVERSIONPREFIX= v
-DISTVERSION= 2.2
+DISTVERSION= 2.3
CATEGORIES= comms net
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${DISTVERSIONFULL}/:server
DISTFILES= ${SERVER_FILE}:server
diff --git a/comms/scrcpy/distinfo b/comms/scrcpy/distinfo
index d943f5b97b12..71feea181163 100644
--- a/comms/scrcpy/distinfo
+++ b/comms/scrcpy/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1699359511
-SHA256 (scrcpy-server-v2.2) = c85c4aa84305efb69115cd497a120ebdd10258993b4cf123a8245b3d99d49874
-SIZE (scrcpy-server-v2.2) = 64363
-SHA256 (Genymobile-scrcpy-v2.2_GH0.tar.gz) = 9c96ce84129e6a4c15da8b907e4576c945732e666fcc52cf94ff402b9dd10c2c
-SIZE (Genymobile-scrcpy-v2.2_GH0.tar.gz) = 396529
+TIMESTAMP = 1701344230
+SHA256 (scrcpy-server-v2.3) = 8daed514d7796fca6987dc973e201bd15ba51d0f7258973dec92d9ded00dbd5f
+SIZE (scrcpy-server-v2.3) = 65851
+SHA256 (Genymobile-scrcpy-v2.3_GH0.tar.gz) = 70937335be7c8b0be3dcf4ae2b0371e5dbe6cf340bf4ccb341be3d10fc039c36
+SIZE (Genymobile-scrcpy-v2.3_GH0.tar.gz) = 400908
diff --git a/comms/scrcpy/files/patch-app_meson.build b/comms/scrcpy/files/patch-app_meson.build
index ba903216f3fc..dd5e6f2abccd 100644
--- a/comms/scrcpy/files/patch-app_meson.build
+++ b/comms/scrcpy/files/patch-app_meson.build
@@ -1,6 +1,6 @@
---- app/meson.build.orig 2023-06-21 23:15:44 UTC
+--- app/meson.build.orig 2023-11-25 20:40:27 UTC
+++ app/meson.build
-@@ -56,8 +56,8 @@ src = [
+@@ -56,8 +56,8 @@ conf = configuration_data()
conf = configuration_data()
@@ -11,7 +11,7 @@
conf.set('_GNU_SOURCE', true)
if host_machine.system() == 'windows'
-@@ -238,10 +238,10 @@ install_data('data/icon.png',
+@@ -185,10 +185,10 @@ install_data('data/bash-completion/scrcpy',
install_data('data/zsh-completion/_scrcpy',
install_dir: join_paths(datadir, 'zsh/site-functions'))
install_data('data/bash-completion/scrcpy',
diff --git a/comms/scrcpy/files/patch-app_src_cli.c b/comms/scrcpy/files/patch-app_src_cli.c
new file mode 100644
index 000000000000..c30acc3a7d98
--- /dev/null
+++ b/comms/scrcpy/files/patch-app_src_cli.c
@@ -0,0 +1,19 @@
+--- app/src/cli.c.orig 2023-11-30 22:01:51 UTC
++++ app/src/cli.c
+@@ -2154,7 +2154,7 @@ parse_args_with_getopt(struct scrcpy_cli_args *args, i
+ return false;
+ }
+ break;
+- case OPT_ORIENTATION:
++ case OPT_ORIENTATION: {
+ enum sc_orientation orientation;
+ if (!parse_orientation(optarg, &orientation)) {
+ return false;
+@@ -2162,6 +2162,7 @@ parse_args_with_getopt(struct scrcpy_cli_args *args, i
+ opts->display_orientation = orientation;
+ opts->record_orientation = orientation;
+ break;
++ }
+ case OPT_RENDER_DRIVER:
+ opts->render_driver = optarg;
+ break;