aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-09-17 17:28:50 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-09-18 10:40:27 +0000
commit42ce6b36ff709ca04247b85eec6b4e8f370ec2e3 (patch)
treedf84232c6c17244472a1207556642f90b30950a6
parente0bf6028ccdc3e32cafc2637dd268e4cf41e79bf (diff)
downloadports-42ce6b36ff709ca04247b85eec6b4e8f370ec2e3.tar.gz
ports-42ce6b36ff709ca04247b85eec6b4e8f370ec2e3.zip
multimedia/motion: Fix build
Update patch with fix from upstream. PR: 272494 Reported by: alexvpetrov@gmail.com Approved by: ports@blievers.net (maintainer, timeout > 2 weeks)
-rw-r--r--multimedia/motion/Makefile4
-rw-r--r--multimedia/motion/distinfo4
-rw-r--r--multimedia/motion/files/patch-configure.ac11
3 files changed, 15 insertions, 4 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 1e3a5251006b..e90cd7e207f6 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -1,7 +1,7 @@
# PORTNAME block
PORTNAME= motion
PORTVERSION= 4.3.2
-PORTREVISION= 7
+PORTREVISION= 8
DISTVERSIONPREFIX= release-
CATEGORIES= multimedia
@@ -14,8 +14,6 @@ WWW= https://motion-project.github.io/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/doc/COPYING
-BROKEN= fails to compile: undefined symbol: WebP*
-
# Dependencies
LIB_DEPENDS= libwebp.so:graphics/webp \
libmicrohttpd.so:www/libmicrohttpd
diff --git a/multimedia/motion/distinfo b/multimedia/motion/distinfo
index 33c442065554..c05734dbfad2 100644
--- a/multimedia/motion/distinfo
+++ b/multimedia/motion/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1603754625
+TIMESTAMP = 1695017850
SHA256 (Motion-Project-motion-release-4.3.2_GH0.tar.gz) = dafa4264b2d8e4778f8be5871f09b6c0ec710d5a836182c583469c18db944d70
SIZE (Motion-Project-motion-release-4.3.2_GH0.tar.gz) = 849378
+SHA256 (af632f831127499ee541d9c719a930321718f294.patch) = 85dc0562c7dc358084c8c9556ebb8ef1592527d79f576f035f356bbdadf40c6c
+SIZE (af632f831127499ee541d9c719a930321718f294.patch) = 890
diff --git a/multimedia/motion/files/patch-configure.ac b/multimedia/motion/files/patch-configure.ac
index 90ec4379d3b6..69fd60bb46d9 100644
--- a/multimedia/motion/files/patch-configure.ac
+++ b/multimedia/motion/files/patch-configure.ac
@@ -1,5 +1,16 @@
--- configure.ac.orig 2020-10-25 20:53:44 UTC
+++ configure.ac
+@@ -181,8 +181,8 @@ AS_IF([test "${WEBP}" = "yes" ], [
+ AS_IF([pkg-config libwebpmux ], [
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_WEBP], [1], [Define to 1 if WEBP is around])
+- TEMP_CFLAGS="$TEMP_CFLAGS "`pkg-config --cflags libwebpmux`
+- TEMP_LIBS="$TEMP_LIBS "`pkg-config --libs libwebpmux`
++ TEMP_CPPFLAGS="$TEMP_CPPFLAGS "`pkgconf --cflags libwebpmux libwebp`
++ TEMP_LIBS="$TEMP_LIBS "`pkgconf --libs libwebpmux libwebp`
+ ],[
+ AC_MSG_RESULT(no)
+ ]
@@ -327,15 +327,11 @@ AS_IF([test "${MYSQL}" = "no"], [
AC_MSG_CHECKING(for MySQL)
AC_MSG_RESULT(skipped)