aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2022-07-09 13:38:45 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2022-07-09 18:04:28 +0000
commit42fd268cb590ab1d7668d5a51b7533067664c699 (patch)
tree57854c3d4b0616c0ff8eed6078bda2654b09d448
parent50ac8c2826117ac1700a8ab2e014f7fa20b99abb (diff)
downloadports-42fd268cb590ab1d7668d5a51b7533067664c699.tar.gz
ports-42fd268cb590ab1d7668d5a51b7533067664c699.zip
Mk/Uses/go.mk: Add GOAMD64 to the GO_ENV
This passes GOAMD64 to the build and test targets.
-rw-r--r--Mk/Uses/go.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/Uses/go.mk b/Mk/Uses/go.mk
index b707b8f4c676..97d370329002 100644
--- a/Mk/Uses/go.mk
+++ b/Mk/Uses/go.mk
@@ -118,6 +118,7 @@ GO_WRKDIR_BIN= ${WRKDIR}/bin
GO_ENV+= CGO_ENABLED=${CGO_ENABLED} \
CGO_CFLAGS="${CGO_CFLAGS}" \
CGO_LDFLAGS="${CGO_LDFLAGS}" \
+ GOAMD64=${GOAMD64} \
GOARM=${GOARM}
. if ${go_ARGS:Mmodules}