aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:21:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:44:31 +0000
commit4331697476fbf8604c43e339d35b0d29d9bb270b (patch)
tree0164433a944990bb3b6d98cca31d350fae8ee51a
parent78b241f328f720a3320723ebf772fb87342406d5 (diff)
downloadports-4331697476fbf8604c43e339d35b0d29d9bb270b.tar.gz
ports-4331697476fbf8604c43e339d35b0d29d9bb270b.zip
devel/py-cffi: Update to 1.16.0
- Convert to USE_PYTHON=pep517 Changes: https://cffi.readthedocs.io/en/latest/whatsnew.html
-rw-r--r--devel/py-cffi/Makefile6
-rw-r--r--devel/py-cffi/distinfo6
-rw-r--r--devel/py-cffi/files/patch-pyproject.toml10
3 files changed, 17 insertions, 5 deletions
diff --git a/devel/py-cffi/Makefile b/devel/py-cffi/Makefile
index 6d88c04ec0c4..79904f217a35 100644
--- a/devel/py-cffi/Makefile
+++ b/devel/py-cffi/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cffi
-PORTVERSION= 1.15.1
+PORTVERSION= 1.16.0
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +11,13 @@ WWW= https://cffi.readthedocs.io/en/latest/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libffi.so:devel/libffi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycparser>=0:devel/py-pycparser@${PY_FLAVOR}
USES= compiler:c11 localbase python
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent cython pep517 pytest
TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
diff --git a/devel/py-cffi/distinfo b/devel/py-cffi/distinfo
index 4fe12fe7870c..2d0049e86f8b 100644
--- a/devel/py-cffi/distinfo
+++ b/devel/py-cffi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656702494
-SHA256 (cffi-1.15.1.tar.gz) = d400bfb9a37b1351253cb402671cea7e89bdecc294e8016a707f6d1d8ac934f9
-SIZE (cffi-1.15.1.tar.gz) = 508501
+TIMESTAMP = 1696001344
+SHA256 (cffi-1.16.0.tar.gz) = bcb3ef43e58665bbda2fb198698fcae6776483e0c4a631aa5647806c25e02cc0
+SIZE (cffi-1.16.0.tar.gz) = 512873
diff --git a/devel/py-cffi/files/patch-pyproject.toml b/devel/py-cffi/files/patch-pyproject.toml
new file mode 100644
index 000000000000..fae4b511f9a7
--- /dev/null
+++ b/devel/py-cffi/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2023-09-28 17:43:07 UTC
++++ pyproject.toml
+@@ -2,6 +2,6 @@
+ requires = [
+ # first version that supports Python 3.12; older versions may work
+ # with previous Python versions, but are not tested
+- "setuptools >= 66.1"
++ "setuptools >= 61"
+ ]
+ build-backend = "setuptools.build_meta"