aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-06-19 03:35:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-06-19 03:36:42 +0000
commit437ca5c821317f6518fd906ee0d4e203c1f3db59 (patch)
tree030a730cfb2df3335b426c534c2c714b92d78944
parentcf3f032b07e7e538ef61829f16634099bbad223b (diff)
downloadports-437ca5c821317f6518fd906ee0d4e203c1f3db59.tar.gz
ports-437ca5c821317f6518fd906ee0d4e203c1f3db59.zip
devel/py-connexion: New port: Connexion: API first applications with OpenAPI/Swagger
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-connexion/Makefile35
-rw-r--r--devel/py-connexion/distinfo3
-rw-r--r--devel/py-connexion/pkg-descr7
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f3816fa3dd2f..7df323a319f8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4601,6 +4601,7 @@
SUBDIR += py-confusable_homoglyphs
SUBDIR += py-confuse
SUBDIR += py-connection_pool
+ SUBDIR += py-connexion
SUBDIR += py-cons
SUBDIR += py-constantly
SUBDIR += py-construct
diff --git a/devel/py-connexion/Makefile b/devel/py-connexion/Makefile
new file mode 100644
index 000000000000..006cd21f7b4c
--- /dev/null
+++ b/devel/py-connexion/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= connexion
+PORTVERSION= 3.1.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Connexion: API first applications with OpenAPI/Swagger
+WWW= https://connexion.readthedocs.io/en/latest/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>0:devel/py-poetry-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0.0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}asgiref>=3.4:www/py-asgiref@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httpx>=0.23:www/py-httpx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}inflection>=0.3.1:devel/py-inflection@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.17.3:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-multipart>=0.0.5:www/py-python-multipart@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.27:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}starlette>=0.35:www/py-starlette@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.6.1:devel/py-typing-extensions@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}werkzeug>=2.2.1:www/py-werkzeug@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest # 3 tests fail, see https://github.com/youknowone/wirerope/issues/22
+
+#USE_GITHUB= yes
+#GH_ACCOUNT= spec-first
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-connexion/distinfo b/devel/py-connexion/distinfo
new file mode 100644
index 000000000000..f3027768f7fa
--- /dev/null
+++ b/devel/py-connexion/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1718767912
+SHA256 (connexion-3.1.0.tar.gz) = 66a44580991f53955b6e409a84fa9fa65c7ca4db52dc217b49cd35c201066083
+SIZE (connexion-3.1.0.tar.gz) = 88189
diff --git a/devel/py-connexion/pkg-descr b/devel/py-connexion/pkg-descr
new file mode 100644
index 000000000000..3a816b9a4e7c
--- /dev/null
+++ b/devel/py-connexion/pkg-descr
@@ -0,0 +1,7 @@
+Connexion is a modern Python web framework that makes spec-first and api-first
+development easy. You describe your API in an OpenAPI (or Swagger) specification
+with as much detail as you want and Connexion will guarantee that it works as
+you specified.
+
+It works either standalone, or in combination with any ASGI or WSGI-compatible
+framework.