aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:14:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:35:24 +0000
commit43ac2e6010d63a65bc58ee765cc28e28f961e4e3 (patch)
tree8920fedfa399aa721ab4fe5601467d4d7989aa04
parentda3f025ae2349cc7a34f5a218b80b3b9163786fc (diff)
downloadports-43ac2e6010d63a65bc58ee765cc28e28f961e4e3.tar.gz
ports-43ac2e6010d63a65bc58ee765cc28e28f961e4e3.zip
devel/py-flit: Update to 3.2.0
-rw-r--r--devel/py-flit/Makefile9
-rw-r--r--devel/py-flit/distinfo6
-rw-r--r--devel/py-flit/files/setup.py35
3 files changed, 44 insertions, 6 deletions
diff --git a/devel/py-flit/Makefile b/devel/py-flit/Makefile
index e65269cf3022..dce29c8cf9d8 100644
--- a/devel/py-flit/Makefile
+++ b/devel/py-flit/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= flit
-PORTVERSION= 3.1.0
+PORTVERSION= 3.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,13 +13,16 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0:textproc/py-docutils@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}flit-core>=${PORTVERSION}:devel/py-flit-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flit-core>=${PORTVERSION}<3.3:devel/py-flit-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+post-patch:
+ @${CP} ${FILESDIR}/setup.py ${WRKSRC}
+
.include <bsd.port.mk>
diff --git a/devel/py-flit/distinfo b/devel/py-flit/distinfo
index b985e0431a1b..e0923bbb5772 100644
--- a/devel/py-flit/distinfo
+++ b/devel/py-flit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1618320134
-SHA256 (flit-3.1.0.tar.gz) = c45104d677572958cbe63ae99011bed16b6e1cf5d6620bc6a8c6f1cfcd7aa40b
-SIZE (flit-3.1.0.tar.gz) = 110402
+TIMESTAMP = 1619198495
+SHA256 (flit-3.2.0.tar.gz) = 592464c9268bbacec9bc67b5a3ae62e6e090aeec1563e69501df338a1728e551
+SIZE (flit-3.2.0.tar.gz) = 115192
diff --git a/devel/py-flit/files/setup.py b/devel/py-flit/files/setup.py
new file mode 100644
index 000000000000..aee70ac43151
--- /dev/null
+++ b/devel/py-flit/files/setup.py
@@ -0,0 +1,35 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['flit', 'flit.vcs', 'flit.vendorized', 'flit.vendorized.readme']
+
+package_data = \
+{'': ['*'], 'flit': ['license_templates/*']}
+
+install_requires = \
+['flit_core>=3.2.0', 'requests', 'docutils', 'toml']
+
+extras_require = \
+{":python_version in '3.3 3.4 3.5'": ['zipfile36'],
+ 'doc': ['sphinx', 'sphinxcontrib_github_alt', 'pygments-github-lexers'],
+ 'test': ['testpath', 'responses', 'pytest>=2.7.3', 'pytest-cov']}
+
+entry_points = \
+{'console_scripts': ['flit = flit:main']}
+
+setup(name='flit',
+ version='3.2.0',
+ description='A simple packaging tool for simple packages.',
+ author='Thomas Kluyver',
+ author_email='thomas@kluyver.me.uk',
+ url='https://flit.readthedocs.io/en/latest/',
+ packages=packages,
+ package_data=package_data,
+ install_requires=install_requires,
+ extras_require=extras_require,
+ entry_points=entry_points,
+ python_requires='>=3.5',
+ )