aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2021-10-18 18:06:44 +0000
committerDan Langille <dvl@FreeBSD.org>2021-10-18 18:06:44 +0000
commit43f214641272504d6f81c2a5f234ea6916daf104 (patch)
treedbfa7dddcc8b97ad461e93365978f3737e950d24
parent1dc572043b79f58bf52f294942840c9b1112a783 (diff)
downloadports-43f214641272504d6f81c2a5f234ea6916daf104.tar.gz
ports-43f214641272504d6f81c2a5f234ea6916daf104.zip
security/py-django-auth-kerberos: Add new port
Kerberos authentication backend for Django
-rw-r--r--security/Makefile1
-rw-r--r--security/py-django-auth-kerberos/Makefile23
-rw-r--r--security/py-django-auth-kerberos/distinfo3
-rw-r--r--security/py-django-auth-kerberos/pkg-descr23
4 files changed, 50 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index fa4843fb6453..ddea687fb5ad 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -899,6 +899,7 @@
SUBDIR += py-dfdatetime
SUBDIR += py-dfvfs
SUBDIR += py-dfwinreg
+ SUBDIR += py-django-auth-kerberos
SUBDIR += py-docker-pycreds
SUBDIR += py-ecdsa
SUBDIR += py-ed25519ll
diff --git a/security/py-django-auth-kerberos/Makefile b/security/py-django-auth-kerberos/Makefile
new file mode 100644
index 000000000000..33a562cdf840
--- /dev/null
+++ b/security/py-django-auth-kerberos/Makefile
@@ -0,0 +1,23 @@
+# Created by: Dan Langille<dvl@freebsd.org>
+
+PORTNAME= django-auth-kerberos
+PORTVERSION= 1.2.5
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= Kerberos authentication backend for Django
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}kerberos>1.1.10:security/py-kerberos@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-django-auth-kerberos/distinfo b/security/py-django-auth-kerberos/distinfo
new file mode 100644
index 000000000000..f0566190bef2
--- /dev/null
+++ b/security/py-django-auth-kerberos/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634568292
+SHA256 (django-auth-kerberos-1.2.5.tar.gz) = ff5a3838baceddd1bc249795723c64491619823ad6849ec3be4b0fdc214df8e9
+SIZE (django-auth-kerberos-1.2.5.tar.gz) = 2277
diff --git a/security/py-django-auth-kerberos/pkg-descr b/security/py-django-auth-kerberos/pkg-descr
new file mode 100644
index 000000000000..c40b8cfece50
--- /dev/null
+++ b/security/py-django-auth-kerberos/pkg-descr
@@ -0,0 +1,23 @@
+Make sure following settings are configured in settings.py:
+
+INSTALLED_APPS = (
+ ...
+ 'django_auth_kerberos',
+ ...
+)
+
+# kerberos realm and service
+KRB5_REALM = 'EXAMPLE.COM'
+KRB5_SERVICE = '[hostname]/EXAMPLE.COM'
+
+# Enabled KDC verification defending against rogue KDC responses
+# by validating the ticket against the local keytab.
+KRB5_VERIFY_KDC = True
+
+# Enable case-sensitive matching between Kerberos and database user names
+KRB5_USERNAME_MATCH_IEXACT = True
+
+# redirect url after login
+LOGIN_REDIRECT_URL = '/'
+
+WWW: https://github.com/02strich/django-auth-kerberos