aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Menelkir <menelkir@itroll.org>2021-08-01 10:59:04 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-08-01 11:00:24 +0000
commit43f89c81129bc2ad3b1bc21a70646d7bd75c374d (patch)
tree64778d7c11cf1ba40230311a1a1c9c3a6ca47ce3
parent85219598c47f5023fd3aa88b64e6c88493361b0e (diff)
downloadports-43f89c81129bc2ad3b1bc21a70646d7bd75c374d.tar.gz
ports-43f89c81129bc2ad3b1bc21a70646d7bd75c374d.zip
audio/strawberry: Change default audio option and add LIB_DEPEND
* Changed the default options for audio to ALSA * Added databases/qt5-sqldrivers-sqlite3 as a LIB_DEPEND. It'll be installed automatically if you use something like KDE, but straberry will fail to load if you use a minimalist WM for example. PR: 257440
-rw-r--r--audio/strawberry/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/strawberry/Makefile b/audio/strawberry/Makefile
index e0355aa3b638..34497736cf03 100644
--- a/audio/strawberry/Makefile
+++ b/audio/strawberry/Makefile
@@ -1,6 +1,6 @@
PORTNAME= strawberry
DISTVERSION= 0.9.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= https://github.com/strawberrymusicplayer/${PORTNAME}/releases/download/${DISTVERSION}/ \
https://files.jkvinge.net/packages/strawberry/
@@ -24,7 +24,8 @@ USES= compiler:c++11-lang cmake desktop-file-utils gnome \
USE_GNOME= glib20
USE_GSTREAMER1= yes
USE_QT= buildtools_build concurrent core dbus gui network \
- linguisttools qmake_build sql testlib_build widgets x11extras
+ linguisttools qmake_build sql sql-sqlite3 testlib_build \
+ widgets x11extras
USE_XORG= ice sm x11 xcb xext
INSTALLS_ICONS= yes
@@ -45,7 +46,7 @@ TEST_TARGET= strawberry_test
OPTIONS_DEFINE= AUDIOCD IPOD MOODBAR MTPDEV MUSICBRAINZ \
SUBSONIC TIDAL VLC
-OPTIONS_DEFAULT= PULSEAUDIO MOODBAR
+OPTIONS_DEFAULT= ALSA MOODBAR
OPTIONS_MULTI= SOUND
OPTIONS_MULTI_SOUND= ALSA PULSEAUDIO