aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-07 06:31:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-07 06:31:23 +0000
commit44138e5a16fcad317b2393b656a8899a082c23d9 (patch)
treef539b4b5329b235f42cc7b3eeb786974090f30d3
parent74a3ce7db549e9af545bb125f04dfd489972f85f (diff)
downloadports-44138e5a16fcad317b2393b656a8899a082c23d9.tar.gz
ports-44138e5a16fcad317b2393b656a8899a082c23d9.zip
misc/py-boost-histogram: New port: Python bindings for the C++14 Boost::Histogram library
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-boost-histogram/Makefile27
-rw-r--r--misc/py-boost-histogram/distinfo3
-rw-r--r--misc/py-boost-histogram/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 835823309860..113fc9cf8b6d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -372,6 +372,7 @@
SUBDIR += py-SimpleSoapy
SUBDIR += py-SoapySDR
SUBDIR += py-alive-progress
+ SUBDIR += py-boost-histogram
SUBDIR += py-cinder
SUBDIR += py-colorbrewer
SUBDIR += py-colored
diff --git a/misc/py-boost-histogram/Makefile b/misc/py-boost-histogram/Makefile
new file mode 100644
index 000000000000..0f5490b70591
--- /dev/null
+++ b/misc/py-boost-histogram/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= boost-histogram
+DISTVERSION= 1.3.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python bindings for the C++14 Boost::Histogram library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/config.hpp:devel/boost-libs
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cloudpickle>0:devel/py-cloudpickle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hypothesis>=6.0:devel/py-hypothesis@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-benchmark>0:devel/py-pytest-benchmark@${PY_FLAVOR}
+
+USES= compiler:c++14-lang python:3.6+
+USE_PYTHON= distutils autoplist pytest
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/boost_histogram/_core.cpython-${PYTHON_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/misc/py-boost-histogram/distinfo b/misc/py-boost-histogram/distinfo
new file mode 100644
index 000000000000..73d0ae9d2d1f
--- /dev/null
+++ b/misc/py-boost-histogram/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659851451
+SHA256 (boost_histogram-1.3.1.tar.gz) = 31cd396656f3a37834e07d304cdb84d9906bc2172626a3d92fe577d08bcf410f
+SIZE (boost_histogram-1.3.1.tar.gz) = 1157843
diff --git a/misc/py-boost-histogram/pkg-descr b/misc/py-boost-histogram/pkg-descr
new file mode 100644
index 000000000000..f7ee4a83b860
--- /dev/null
+++ b/misc/py-boost-histogram/pkg-descr
@@ -0,0 +1,5 @@
+Python bindings for Boost::Histogram, a C++14 library. This is one of the
+fastest libraries for histogramming, while still providing the power of a full
+histogram object.
+
+WWW: https://github.com/scikit-hep/boost-histogram