aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2023-09-13 05:48:02 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2023-09-13 05:48:57 +0000
commit44751f5f02191e232afe5c327cad3d50382ba497 (patch)
treeeefd9fd19817ef6a65234cd42f667f80e13bec36
parentec37f68193bf82ad8532fb59532230340f1cfee8 (diff)
downloadports-44751f5f02191e232afe5c327cad3d50382ba497.tar.gz
ports-44751f5f02191e232afe5c327cad3d50382ba497.zip
devel/libgit2: fix build problem with openssl3 and libressl
Make cmake aware of the selected ssl lib PR: 273609
-rw-r--r--devel/libgit2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index 6077ec583236..57dea0d9397e 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -24,7 +24,10 @@ USE_LDCONFIG= yes
CMAKE_TESTING_ON= BUILD_TESTS
CMAKE_ARGS= -DREGEX_BACKEND=pcre2 -DUSE_HTTP_PARSER=system \
- -DCMAKE_CTEST_ARGUMENTS="-E;'invasive|online'"
+ -DCMAKE_CTEST_ARGUMENTS="-E;'invasive|online'" \
+ -DOPENSSL_ROOT_DIR=${OPENSSLBASE} \
+ -DOPENSSL_ENGINES_DIR=${ENGINESDIR}
+
CMAKE_OFF= BUILD_TESTS
PLIST_SUB= DISTVERSION=${DISTVERSION} \