aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-07-08 18:03:56 +0000
committerCy Schubert <cy@FreeBSD.org>2021-07-08 18:03:56 +0000
commit44dadc459ac045d871cd3580aa0ba351362e4a29 (patch)
tree1bd5284b78b87eb7e5026074c5edb8f1a1f9d550
parent5dcc4b00c0245b4c9834eec2abb7f226ce9a0e42 (diff)
downloadports-44dadc459ac045d871cd3580aa0ba351362e4a29.tar.gz
ports-44dadc459ac045d871cd3580aa0ba351362e4a29.zip
net/freebsd-telnetd: Add net/freebsd-telnetd
This new port contains the legacy FreeBSD telnetd which will be removed from FreeBSD-14.
-rw-r--r--net/Makefile1
-rw-r--r--net/freebsd-telnetd/Makefile41
-rw-r--r--net/freebsd-telnetd/distinfo3
-rw-r--r--net/freebsd-telnetd/files/Makefile.in8
-rw-r--r--net/freebsd-telnetd/files/patch-lib_libtelnet_Makefile10
-rw-r--r--net/freebsd-telnetd/files/patch-libexec_telnetd_Makefile20
-rw-r--r--net/freebsd-telnetd/pkg-descr4
-rw-r--r--net/freebsd-telnetd/pkg-plist2
8 files changed, 89 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 06d42b083da1..c4dcdcab2497 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -159,6 +159,7 @@
SUBDIR += fpc-libenet
SUBDIR += fpc-pcap
SUBDIR += fping
+ SUBDIR += freebsd-telnetd
SUBDIR += freebsd-uucp
SUBDIR += freediameter
SUBDIR += freeradius-client
diff --git a/net/freebsd-telnetd/Makefile b/net/freebsd-telnetd/Makefile
new file mode 100644
index 000000000000..de926fc32a2d
--- /dev/null
+++ b/net/freebsd-telnetd/Makefile
@@ -0,0 +1,41 @@
+# Created by: cy@FreeBSD.org
+
+PORTNAME= freebsd-telnetd
+DISTVERSIONPREFIX= v
+DISTVERSION= 14.0
+CATEGORIES= net
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= FreeBSD telnetd
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= cschuber
+GH_PROJECT= freebsd-telnet
+
+USES= uidfix
+
+MAKE_ARGS+= BINOWN=${BINOWN} BINMODE=${BINMODE}
+MAKE_ENV+= MAKESYSPATH=/usr/src/share/mk \
+ BINDIR=${PREFIX}/libexec \
+ MANDIR=${PREFIX}/man/man \
+ TELNETDIR=${WRKSRC}/contrib/telnet
+
+OPTIONS_DEFINE= IPV6
+OPTIONS_DEFAULT= IPV6
+
+# WRKSRC_SUBDIR= libexec/telnetd
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300134
+MAKE_ENV+= MK_WERROR=no
+.else
+MAKE_ENV+= NO_WERROR=1
+.endif
+
+post-patch:
+ @${CP} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/freebsd-telnetd/distinfo b/net/freebsd-telnetd/distinfo
new file mode 100644
index 000000000000..8136c2373cda
--- /dev/null
+++ b/net/freebsd-telnetd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1624075050
+SHA256 (cschuber-freebsd-telnet-v14.0_GH0.tar.gz) = eb1a8bc4e6c3c50502eea653fe5a9fa338cea4a4c7dab575c8f4222a57210945
+SIZE (cschuber-freebsd-telnet-v14.0_GH0.tar.gz) = 149901
diff --git a/net/freebsd-telnetd/files/Makefile.in b/net/freebsd-telnetd/files/Makefile.in
new file mode 100644
index 000000000000..e7bd81ca7c33
--- /dev/null
+++ b/net/freebsd-telnetd/files/Makefile.in
@@ -0,0 +1,8 @@
+.include <src.opts.mk>
+
+SUBDIR= lib/libtelnet \
+ libexec/telnetd
+
+.include <bsd.arch.inc.mk>
+
+.include <bsd.subdir.mk>
diff --git a/net/freebsd-telnetd/files/patch-lib_libtelnet_Makefile b/net/freebsd-telnetd/files/patch-lib_libtelnet_Makefile
new file mode 100644
index 000000000000..e1c39d5e9bd3
--- /dev/null
+++ b/net/freebsd-telnetd/files/patch-lib_libtelnet_Makefile
@@ -0,0 +1,10 @@
+--- lib/libtelnet/Makefile.orig 2020-12-29 13:05:48.000000000 -0800
++++ lib/libtelnet/Makefile 2021-07-08 10:14:06.131869000 -0700
+@@ -4,7 +4,6 @@
+ .include <src.opts.mk>
+
+ PACKAGE=lib${LIB}
+-TELNETDIR= ${SRCTOP}/contrib/telnet
+ .PATH: ${TELNETDIR}/libtelnet
+
+ LIB= telnet
diff --git a/net/freebsd-telnetd/files/patch-libexec_telnetd_Makefile b/net/freebsd-telnetd/files/patch-libexec_telnetd_Makefile
new file mode 100644
index 000000000000..a836f391dc53
--- /dev/null
+++ b/net/freebsd-telnetd/files/patch-libexec_telnetd_Makefile
@@ -0,0 +1,20 @@
+--- libexec/telnetd/Makefile.orig 2020-12-29 13:05:48.000000000 -0800
++++ libexec/telnetd/Makefile 2021-07-08 10:59:49.657276000 -0700
+@@ -5,7 +5,6 @@
+
+ .include <src.opts.mk>
+
+-TELNETDIR= ${SRCTOP}/contrib/telnet
+ .PATH: ${TELNETDIR}/telnetd
+
+ PROG= telnetd
+@@ -18,7 +17,8 @@
+ WFORMAT?= 0
+
+ CFLAGS+= -DLINEMODE -DUSE_TERMIO -DDIAGNOSTICS -DOLD_ENVIRON \
+- -DENV_HACK -DSTREAMSPTY
++ -DENV_HACK -DSTREAMSPTY \
++ -L${TELNETDIR}/../../lib/libtelnet
+
+ .if ${MK_INET6_SUPPORT} != "no"
+ CFLAGS+= -DINET6
diff --git a/net/freebsd-telnetd/pkg-descr b/net/freebsd-telnetd/pkg-descr
new file mode 100644
index 000000000000..8f8c55440193
--- /dev/null
+++ b/net/freebsd-telnetd/pkg-descr
@@ -0,0 +1,4 @@
+FreeBSD-telnetd: This is/was FreeBSD libexec/telnetd prior to its removal
+in FreeBSD-14.
+
+WWW: https://github.com/cschuber/freebsd-telnetd
diff --git a/net/freebsd-telnetd/pkg-plist b/net/freebsd-telnetd/pkg-plist
new file mode 100644
index 000000000000..e17aad8d2c26
--- /dev/null
+++ b/net/freebsd-telnetd/pkg-plist
@@ -0,0 +1,2 @@
+libexec/telnetd
+man/man8/telnetd.8.gz