aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-03-20 14:49:42 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-03-22 20:15:18 +0000
commit452bf31af319759bfb289c3174cbe75676ee7e32 (patch)
treec43a0c3859a49edacb2438edbc9d2b5207682281
parentf57e6fd95aadc6524509155ff0ca3604353efc16 (diff)
downloadports-452bf31af319759bfb289c3174cbe75676ee7e32.tar.gz
ports-452bf31af319759bfb289c3174cbe75676ee7e32.zip
www/amfora: fix build on riscv64
Bump golang.org/x/sys dependency to a version new enough to support riscv64-freebsd. Sponsored by: Berliner Linux User Group e.V. Approved by: portmgr (build fix blanket)
-rw-r--r--www/amfora/Makefile8
-rw-r--r--www/amfora/distinfo4
-rw-r--r--www/amfora/files/patch-go.mod67
-rw-r--r--www/amfora/files/patch-go.sum19
-rw-r--r--www/amfora/files/patch-vendor_modules.txt175
5 files changed, 271 insertions, 2 deletions
diff --git a/www/amfora/Makefile b/www/amfora/Makefile
index acf5a7d5a9e2..115d2d234619 100644
--- a/www/amfora/Makefile
+++ b/www/amfora/Makefile
@@ -1,7 +1,7 @@
PORTNAME= amfora
DISTVERSIONPREFIX= v
DISTVERSION= 1.9.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= www
MAINTAINER= lcook@FreeBSD.org
@@ -12,6 +12,8 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules
+USE_GITHUB= nodefault
+GH_TUPLE= golang:sys:v0.6.0:sys
_BUILD_VERSION= ${DISTVERSIONFULL}
_BUILD_COMMIT= 61d8645
@@ -28,6 +30,10 @@ PORTEXAMPLES= default-config.toml
OPTIONS_DEFINE= DOCS EXAMPLES
+pre-patch:
+ ${RM} -r ${WRKSRC}/vendor/golang.org/x/sys
+ ${LN} -s ${WRKDIR}/sys-* ${WRKSRC}/vendor/golang.org/x/sys
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} \
diff --git a/www/amfora/distinfo b/www/amfora/distinfo
index 35f05e1e57ed..dadc977c5474 100644
--- a/www/amfora/distinfo
+++ b/www/amfora/distinfo
@@ -1,5 +1,7 @@
-TIMESTAMP = 1640191021
+TIMESTAMP = 1679323295
SHA256 (go/www_amfora/amfora-v1.9.2/v1.9.2.mod) = 29117dea2f1459cec179cf38a07abb60dc03eea2c011cc65f93ffacce113c6c0
SIZE (go/www_amfora/amfora-v1.9.2/v1.9.2.mod) = 1163
SHA256 (go/www_amfora/amfora-v1.9.2/v1.9.2.zip) = 155467167963bc155070d4c8068c7e7934c920954f74d919519c68869dc96f2a
SIZE (go/www_amfora/amfora-v1.9.2/v1.9.2.zip) = 2375737
+SHA256 (go/www_amfora/amfora-v1.9.2/golang-sys-v0.6.0_GH0.tar.gz) = b4f6d17c7a128f76169964b437cb66b3f2dbf9a33361928ec19dfecf7b03fc54
+SIZE (go/www_amfora/amfora-v1.9.2/golang-sys-v0.6.0_GH0.tar.gz) = 1434234
diff --git a/www/amfora/files/patch-go.mod b/www/amfora/files/patch-go.mod
new file mode 100644
index 000000000000..bed82c91a959
--- /dev/null
+++ b/www/amfora/files/patch-go.mod
@@ -0,0 +1,67 @@
+--- go.mod.orig 2023-03-20 14:44:32 UTC
++++ go.mod
+@@ -1,30 +1,56 @@
+ module github.com/makeworld-the-better-one/amfora
+
+-go 1.15
++go 1.17
+
+ require (
+ code.rocketnine.space/tslocum/cview v1.5.6-0.20210530175404-7e8817f20bdc
+ github.com/atotto/clipboard v0.1.4
+ github.com/dustin/go-humanize v1.0.0
+- github.com/fsnotify/fsnotify v1.4.9 // indirect
+ github.com/gdamore/tcell/v2 v2.3.3
+- github.com/google/go-cmp v0.5.0 // indirect
+ github.com/makeworld-the-better-one/go-gemini v0.12.1
+ github.com/mitchellh/go-homedir v1.1.0
+- github.com/mitchellh/mapstructure v1.3.1 // indirect
+ github.com/mmcdole/gofeed v1.1.2
+ github.com/muesli/termenv v0.9.0
+- github.com/pelletier/go-toml v1.8.0 // indirect
+ github.com/rkoesters/xdg v0.0.0-20181125232953-edd15b846f9b
+ github.com/schollz/progressbar/v3 v3.8.0
++ github.com/spf13/viper v1.7.1
++ github.com/stretchr/testify v1.6.1
++ golang.org/x/text v0.3.6
++)
++
++require (
++ code.rocketnine.space/tslocum/cbind v0.1.5 // indirect
++ github.com/PuerkitoBio/goquery v1.5.1 // indirect
++ github.com/andybalholm/cascadia v1.1.0 // indirect
++ github.com/davecgh/go-spew v1.1.1 // indirect
++ github.com/fsnotify/fsnotify v1.4.9 // indirect
++ github.com/gdamore/encoding v1.0.0 // indirect
++ github.com/google/go-cmp v0.5.0 // indirect
++ github.com/hashicorp/hcl v1.0.0 // indirect
++ github.com/json-iterator/go v1.1.10 // indirect
++ github.com/lucasb-eyer/go-colorful v1.2.0 // indirect
++ github.com/magiconair/properties v1.8.1 // indirect
++ github.com/mattn/go-isatty v0.0.13 // indirect
++ github.com/mattn/go-runewidth v0.0.13 // indirect
++ github.com/mitchellh/colorstring v0.0.0-20190213212951-d06e56a500db // indirect
++ github.com/mitchellh/mapstructure v1.3.1 // indirect
++ github.com/mmcdole/goxpp v0.0.0-20181012175147-0068e33feabf // indirect
++ github.com/modern-go/concurrent v0.0.0-20180306012644-bacd9c7ef1dd // indirect
++ github.com/modern-go/reflect2 v1.0.1 // indirect
++ github.com/pelletier/go-toml v1.8.0 // indirect
++ github.com/pmezard/go-difflib v1.0.0 // indirect
++ github.com/rivo/uniseg v0.2.0 // indirect
+ github.com/spf13/afero v1.2.2 // indirect
+ github.com/spf13/cast v1.3.1 // indirect
+ github.com/spf13/jwalterweatherman v1.1.0 // indirect
+ github.com/spf13/pflag v1.0.5 // indirect
+- github.com/spf13/viper v1.7.1
+- github.com/stretchr/testify v1.6.1
+- golang.org/x/text v0.3.6
++ github.com/subosito/gotenv v1.2.0 // indirect
++ golang.org/x/crypto v0.0.0-20210220033148-5ea612d1eb83 // indirect
++ golang.org/x/net v0.0.0-20201216054612-986b41b23924 // indirect
++ golang.org/x/sys v0.6.0 // indirect
++ golang.org/x/term v0.0.0-20210503060354-a79de5458b56 // indirect
+ gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15 // indirect
+ gopkg.in/ini.v1 v1.62.0 // indirect
++ gopkg.in/yaml.v2 v2.3.0 // indirect
+ gopkg.in/yaml.v3 v3.0.0-20200615113413-eeeca48fe776 // indirect
+ )
diff --git a/www/amfora/files/patch-go.sum b/www/amfora/files/patch-go.sum
new file mode 100644
index 000000000000..cd562578a4b6
--- /dev/null
+++ b/www/amfora/files/patch-go.sum
@@ -0,0 +1,19 @@
+--- go.sum.orig 2023-03-20 14:44:35 UTC
++++ go.sum
+@@ -319,6 +319,8 @@ golang.org/x/sys v0.0.0-20210223095934-7937bea0104d/go
+ golang.org/x/sys v0.0.0-20210309040221-94ec62e08169/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
+ golang.org/x/sys v0.0.0-20210525143221-35b2ab0089ea h1:+WiDlPBBaO+h9vPNZi8uJ3k4BkKQB7Iow3aqwHVA5hI=
+ golang.org/x/sys v0.0.0-20210525143221-35b2ab0089ea/go.mod h1:oPkhp1MJrh7nUepCBck5+mAzfO9JrbApNNgaTdGDITg=
++golang.org/x/sys v0.6.0 h1:MVltZSvRTcU2ljQOhs94SXPftV6DCNnZViHeQps87pQ=
++golang.org/x/sys v0.6.0/go.mod h1:oPkhp1MJrh7nUepCBck5+mAzfO9JrbApNNgaTdGDITg=
+ golang.org/x/term v0.0.0-20201117132131-f5c789dd3221/go.mod h1:Nr5EML6q2oocZ2LXRh80K7BxOlk5/8JxuGnuhpl+muw=
+ golang.org/x/term v0.0.0-20201126162022-7de9c90e9dd1/go.mod h1:bj7SfCRtBDWHUb9snDiAeCFNEtKQo2Wmx5Cou7ajbmo=
+ golang.org/x/term v0.0.0-20201210144234-2321bbc49cbf/go.mod h1:bj7SfCRtBDWHUb9snDiAeCFNEtKQo2Wmx5Cou7ajbmo=
+@@ -352,7 +354,6 @@ golang.org/x/tools v0.0.0-20190911174233-4f2ddba30aff/
+ golang.org/x/tools v0.0.0-20191012152004-8de300cfc20a/go.mod h1:b+2E5dAYhXwXZwtnZ6UAqBI28+e2cm9otk0dWdXHAEo=
+ golang.org/x/tools v0.0.0-20191112195655-aa38f8e97acc/go.mod h1:b+2E5dAYhXwXZwtnZ6UAqBI28+e2cm9otk0dWdXHAEo=
+ golang.org/x/xerrors v0.0.0-20190717185122-a985d3407aa7/go.mod h1:I/5z698sn9Ka8TeJc9MKroUUfqBBauWjQqLJ2OPfmY0=
+-golang.org/x/xerrors v0.0.0-20191204190536-9bdfabe68543 h1:E7g+9GITq07hpfrRu66IVDexMakfv52eLZ2CXBWiKr4=
+ golang.org/x/xerrors v0.0.0-20191204190536-9bdfabe68543/go.mod h1:I/5z698sn9Ka8TeJc9MKroUUfqBBauWjQqLJ2OPfmY0=
+ google.golang.org/api v0.4.0/go.mod h1:8k5glujaEP+g9n7WNsDg8QP6cUVNI86fCNMcbazEtwE=
+ google.golang.org/api v0.7.0/go.mod h1:WtwebWUNSVBH/HAw79HIFXZNqEvBhG+Ra+ax0hx3E3M=
diff --git a/www/amfora/files/patch-vendor_modules.txt b/www/amfora/files/patch-vendor_modules.txt
new file mode 100644
index 000000000000..81effc03ffb7
--- /dev/null
+++ b/www/amfora/files/patch-vendor_modules.txt
@@ -0,0 +1,175 @@
+--- vendor/modules.txt.orig 2023-03-20 14:45:07 UTC
++++ vendor/modules.txt
+@@ -1,27 +1,32 @@
+ # code.rocketnine.space/tslocum/cbind v0.1.5
++## explicit; go 1.15
+ code.rocketnine.space/tslocum/cbind
+ # code.rocketnine.space/tslocum/cview v1.5.6-0.20210530175404-7e8817f20bdc
+-## explicit
++## explicit; go 1.12
+ code.rocketnine.space/tslocum/cview
+ # github.com/PuerkitoBio/goquery v1.5.1
++## explicit; go 1.13
+ github.com/PuerkitoBio/goquery
+ # github.com/andybalholm/cascadia v1.1.0
++## explicit
+ github.com/andybalholm/cascadia
+ # github.com/atotto/clipboard v0.1.4
+ ## explicit
+ github.com/atotto/clipboard
+ # github.com/davecgh/go-spew v1.1.1
++## explicit
+ github.com/davecgh/go-spew/spew
+ # github.com/dustin/go-humanize v1.0.0
+ ## explicit
+ github.com/dustin/go-humanize
+ # github.com/fsnotify/fsnotify v1.4.9
+-## explicit
++## explicit; go 1.13
+ github.com/fsnotify/fsnotify
+ # github.com/gdamore/encoding v1.0.0
++## explicit; go 1.9
+ github.com/gdamore/encoding
+ # github.com/gdamore/tcell/v2 v2.3.3
+-## explicit
++## explicit; go 1.12
+ github.com/gdamore/tcell/v2
+ github.com/gdamore/tcell/v2/terminfo
+ github.com/gdamore/tcell/v2/terminfo/a/aixterm
+@@ -61,8 +66,9 @@ github.com/gdamore/tcell/v2/terminfo/x/xterm
+ github.com/gdamore/tcell/v2/terminfo/x/xterm_kitty
+ github.com/gdamore/tcell/v2/terminfo/x/xterm_termite
+ # github.com/google/go-cmp v0.5.0
+-## explicit
++## explicit; go 1.8
+ # github.com/hashicorp/hcl v1.0.0
++## explicit
+ github.com/hashicorp/hcl
+ github.com/hashicorp/hcl/hcl/ast
+ github.com/hashicorp/hcl/hcl/parser
+@@ -74,28 +80,34 @@ github.com/hashicorp/hcl/json/parser
+ github.com/hashicorp/hcl/json/scanner
+ github.com/hashicorp/hcl/json/token
+ # github.com/json-iterator/go v1.1.10
++## explicit; go 1.12
+ github.com/json-iterator/go
+ # github.com/lucasb-eyer/go-colorful v1.2.0
++## explicit; go 1.12
+ github.com/lucasb-eyer/go-colorful
+ # github.com/magiconair/properties v1.8.1
++## explicit
+ github.com/magiconair/properties
+ # github.com/makeworld-the-better-one/go-gemini v0.12.1
+-## explicit
++## explicit; go 1.14
+ github.com/makeworld-the-better-one/go-gemini
+ # github.com/mattn/go-isatty v0.0.13
++## explicit; go 1.12
+ github.com/mattn/go-isatty
+ # github.com/mattn/go-runewidth v0.0.13
++## explicit; go 1.9
+ github.com/mattn/go-runewidth
+ # github.com/mitchellh/colorstring v0.0.0-20190213212951-d06e56a500db
++## explicit
+ github.com/mitchellh/colorstring
+ # github.com/mitchellh/go-homedir v1.1.0
+ ## explicit
+ github.com/mitchellh/go-homedir
+ # github.com/mitchellh/mapstructure v1.3.1
+-## explicit
++## explicit; go 1.14
+ github.com/mitchellh/mapstructure
+ # github.com/mmcdole/gofeed v1.1.2
+-## explicit
++## explicit; go 1.14
+ github.com/mmcdole/gofeed
+ github.com/mmcdole/gofeed/atom
+ github.com/mmcdole/gofeed/extensions
+@@ -103,20 +115,25 @@ github.com/mmcdole/gofeed/internal/shared
+ github.com/mmcdole/gofeed/json
+ github.com/mmcdole/gofeed/rss
+ # github.com/mmcdole/goxpp v0.0.0-20181012175147-0068e33feabf
++## explicit
+ github.com/mmcdole/goxpp
+ # github.com/modern-go/concurrent v0.0.0-20180306012644-bacd9c7ef1dd
++## explicit
+ github.com/modern-go/concurrent
+ # github.com/modern-go/reflect2 v1.0.1
++## explicit
+ github.com/modern-go/reflect2
+ # github.com/muesli/termenv v0.9.0
+-## explicit
++## explicit; go 1.13
+ github.com/muesli/termenv
+ # github.com/pelletier/go-toml v1.8.0
+-## explicit
++## explicit; go 1.12
+ github.com/pelletier/go-toml
+ # github.com/pmezard/go-difflib v1.0.0
++## explicit
+ github.com/pmezard/go-difflib/difflib
+ # github.com/rivo/uniseg v0.2.0
++## explicit; go 1.12
+ github.com/rivo/uniseg
+ # github.com/rkoesters/xdg v0.0.0-20181125232953-edd15b846f9b
+ ## explicit
+@@ -124,7 +141,7 @@ github.com/rkoesters/xdg/basedir
+ github.com/rkoesters/xdg/keyfile
+ github.com/rkoesters/xdg/userdirs
+ # github.com/schollz/progressbar/v3 v3.8.0
+-## explicit
++## explicit; go 1.13
+ github.com/schollz/progressbar/v3
+ # github.com/spf13/afero v1.2.2
+ ## explicit
+@@ -137,32 +154,37 @@ github.com/spf13/cast
+ ## explicit
+ github.com/spf13/jwalterweatherman
+ # github.com/spf13/pflag v1.0.5
+-## explicit
++## explicit; go 1.12
+ github.com/spf13/pflag
+ # github.com/spf13/viper v1.7.1
+-## explicit
++## explicit; go 1.12
+ github.com/spf13/viper
+ # github.com/stretchr/testify v1.6.1
+-## explicit
++## explicit; go 1.13
+ github.com/stretchr/testify/assert
+ # github.com/subosito/gotenv v1.2.0
++## explicit
+ github.com/subosito/gotenv
+ # golang.org/x/crypto v0.0.0-20210220033148-5ea612d1eb83
++## explicit; go 1.11
+ golang.org/x/crypto/ssh/terminal
+ # golang.org/x/net v0.0.0-20201216054612-986b41b23924
++## explicit; go 1.11
+ golang.org/x/net/html
+ golang.org/x/net/html/atom
+ golang.org/x/net/html/charset
+ golang.org/x/net/idna
+-# golang.org/x/sys v0.0.0-20210525143221-35b2ab0089ea
++# golang.org/x/sys v0.6.0
++## explicit; go 1.17
+ golang.org/x/sys/internal/unsafeheader
+ golang.org/x/sys/plan9
+ golang.org/x/sys/unix
+ golang.org/x/sys/windows
+ # golang.org/x/term v0.0.0-20210503060354-a79de5458b56
++## explicit; go 1.17
+ golang.org/x/term
+ # golang.org/x/text v0.3.6
+-## explicit
++## explicit; go 1.11
+ golang.org/x/text/encoding
+ golang.org/x/text/encoding/charmap
+ golang.org/x/text/encoding/htmlindex
+@@ -190,6 +212,7 @@ golang.org/x/text/unicode/norm
+ ## explicit
+ gopkg.in/ini.v1
+ # gopkg.in/yaml.v2 v2.3.0
++## explicit
+ gopkg.in/yaml.v2
+ # gopkg.in/yaml.v3 v3.0.0-20200615113413-eeeca48fe776
+ ## explicit