aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-01-09 06:33:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-01-09 06:33:10 +0000
commit4549fc4efa5292326f8e85437f5464bec6352250 (patch)
tree5899d4c0c8a8ec925026033199e1c0f7b73375e2
parentafc79020abd4993028512abe39074222bac83ffc (diff)
downloadports-4549fc4efa5292326f8e85437f5464bec6352250.tar.gz
ports-4549fc4efa5292326f8e85437f5464bec6352250.zip
net/rssguard: the port had been updated to version 4.1.1
Remove the QMediaPlayer -> QSoundEffect patch, it had been accepted upstream in the modified form: QSoundEffect, which does not require GStreamer, is used for *.wav files, and QMediaPlayer for *.mp3, etc. Ditto for the sed(1) call which no longer does anything useful.
-rw-r--r--net/rssguard/Makefile7
-rw-r--r--net/rssguard/distinfo6
-rw-r--r--net/rssguard/files/patch-src_librssguard_miscellaneous_notification.cpp44
3 files changed, 4 insertions, 53 deletions
diff --git a/net/rssguard/Makefile b/net/rssguard/Makefile
index 48d13f3fdfca..340601f2aad1 100644
--- a/net/rssguard/Makefile
+++ b/net/rssguard/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= rssguard
-PORTVERSION= 4.0.4
+PORTVERSION= 4.1.1
CATEGORIES= net www
MAINTAINER= danfe@FreeBSD.org
@@ -28,11 +28,6 @@ WEBENGINE_QMAKE_OFF= USE_WEBENGINE=false
post-patch:
@${GREP} -Rl --null Q_OS_LINUX ${WRKSRC}/src | ${XARGS} -0 \
${REINPLACE_CMD} -e 's,Q_OS_LINUX,Q_OS_UNIX,'
-# Avoid potential linking errors when previous version of the port
-# is installed.
- @${REINPLACE_CMD} -e '/^unix: LIBS/ { s,-L,, ; \
- s, -lrssguard,librssguard.so, ; }' \
- ${WRKSRC}/src/rssguard/rssguard.pro
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librssguard.so
diff --git a/net/rssguard/distinfo b/net/rssguard/distinfo
index c16dfc5d491a..ca9f95fd02f1 100644
--- a/net/rssguard/distinfo
+++ b/net/rssguard/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1634296436
-SHA256 (martinrotter-rssguard-4.0.4_GH0.tar.gz) = 9154a9c674b35f68486ca7e024265e044b7c7971485bafbe9b6ebbdf27463489
-SIZE (martinrotter-rssguard-4.0.4_GH0.tar.gz) = 14433147
+TIMESTAMP = 1641564291
+SHA256 (martinrotter-rssguard-4.1.1_GH0.tar.gz) = 2f9a846f12a1c70ec2d8d474daff4e7caeb14ade332b75f40a9900aa7fbc4994
+SIZE (martinrotter-rssguard-4.1.1_GH0.tar.gz) = 21717154
diff --git a/net/rssguard/files/patch-src_librssguard_miscellaneous_notification.cpp b/net/rssguard/files/patch-src_librssguard_miscellaneous_notification.cpp
deleted file mode 100644
index afee28e7c4a5..000000000000
--- a/net/rssguard/files/patch-src_librssguard_miscellaneous_notification.cpp
+++ /dev/null
@@ -1,44 +0,0 @@
---- src/librssguard/miscellaneous/notification.cpp.orig 2021-10-15 11:13:56 UTC
-+++ src/librssguard/miscellaneous/notification.cpp
-@@ -7,7 +7,7 @@
- #include <QDir>
-
- #if !defined(Q_OS_OS2)
--#include <QMediaPlayer>
-+#include <QSoundEffect>
- #endif
-
- Notification::Notification(Notification::Event event, bool balloon, const QString& sound_path, int volume)
-@@ -32,25 +32,25 @@ void Notification::setSoundPath(const QString& sound_p
- void Notification::playSound(Application* app) const {
- if (!m_soundPath.isEmpty()) {
- #if !defined(Q_OS_OS2)
-- QMediaPlayer* play = new QMediaPlayer(app);
-+ QSoundEffect* play = new QSoundEffect(app);
-
-- QObject::connect(play, &QMediaPlayer::stateChanged, play, [play](QMediaPlayer::State state) {
-- if (state == QMediaPlayer::State::StoppedState) {
-+ QObject::connect(play, &QSoundEffect::playingChanged, play, [play]() {
-+ if (!play->isPlaying()) {
- play->deleteLater();
- }
- });
-
- if (m_soundPath.startsWith(QSL(":"))) {
-- play->setMedia(QMediaContent(QUrl(QSL("qrc") + m_soundPath)));
-+ play->setSource(QUrl(QSL("qrc") + m_soundPath));
-
- }
- else {
-- play->setMedia(QMediaContent(
-+ play->setSource(
- QUrl::fromLocalFile(
-- QDir::toNativeSeparators(app->replaceDataUserDataFolderPlaceholder(m_soundPath)))));
-+ QDir::toNativeSeparators(app->replaceDataUserDataFolderPlaceholder(m_soundPath))));
- }
-
-- play->setVolume(m_volume);
-+ play->setVolume(static_cast<qreal>(m_volume) / 100);
- play->play();
- #endif
- }