aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:35:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:19:58 +0000
commit458fecccbf8778f23c3a90725f622acd0e14f138 (patch)
treeb52b50ddd0ca65b534819802d71624b7fd9fb59d
parent53d268fa12c8f2091a66c0cb1daf7685e854eda6 (diff)
downloadports-458fecccbf8778f23c3a90725f622acd0e14f138.tar.gz
ports-458fecccbf8778f23c3a90725f622acd0e14f138.zip
devel/rubygem-redlock1: Add rubygem-redlock1 1.3.2 (copied from rubygem-redlock)
- Add PORTSCOUT
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-redlock1/Makefile22
-rw-r--r--devel/rubygem-redlock1/distinfo3
-rw-r--r--devel/rubygem-redlock1/pkg-descr13
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 248674d7a79b..a58560ec7325 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7060,6 +7060,7 @@
SUBDIR += rubygem-redis-activesupport-rails61
SUBDIR += rubygem-redis-store
SUBDIR += rubygem-redlock
+ SUBDIR += rubygem-redlock1
SUBDIR += rubygem-redmine_plugin_support
SUBDIR += rubygem-reentrant_flock
SUBDIR += rubygem-ref
diff --git a/devel/rubygem-redlock1/Makefile b/devel/rubygem-redlock1/Makefile
new file mode 100644
index 000000000000..2d19153e8d52
--- /dev/null
+++ b/devel/rubygem-redlock1/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= redlock
+PORTVERSION= 1.3.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 1
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Distributed lock using Redis written in Ruby
+WWW= https://github.com/leandromoreira/redlock-rb
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-redis>=3.0.0<6.0:databases/rubygem-redis
+
+USES= gem
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^1\.
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-redlock1/distinfo b/devel/rubygem-redlock1/distinfo
new file mode 100644
index 000000000000..51daedd2220e
--- /dev/null
+++ b/devel/rubygem-redlock1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674588100
+SHA256 (rubygem/redlock-1.3.2.gem) = 6c7cea3d62c6e31e8df6b1924fdf89e35e5576e52dce10c62412e783bfe37277
+SIZE (rubygem/redlock-1.3.2.gem) = 18432
diff --git a/devel/rubygem-redlock1/pkg-descr b/devel/rubygem-redlock1/pkg-descr
new file mode 100644
index 000000000000..ef8420053e2d
--- /dev/null
+++ b/devel/rubygem-redlock1/pkg-descr
@@ -0,0 +1,13 @@
+Redlock provides a ruby distributed lock using redis.
+
+Distributed locks are a very useful primitive in many environments where
+different processes require to operate with shared resources in a mutually
+exclusive way.
+
+There are a number of libraries and blog posts describing how to implement a DLM
+(Distributed Lock Manager) with Redis, but every library uses a different
+approach, and many use a simple approach with lower guarantees compared to what
+can be achieved with slightly more complex designs.
+
+This is an implementation of a proposed distributed lock algorithm with Redis.
+It started as a fork from antirez implementation.