aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2021-09-10 15:41:44 +0000
committerLewis Cook <lcook@FreeBSD.org>2021-09-10 15:41:44 +0000
commit45909c67741fd9d8f6aaccdd402721cb042fe080 (patch)
tree39e19349dc45054d950b5552705c054f965d71b8
parentaa9644b8d44f2330116dfd6c3ab78a3a7608d928 (diff)
downloadports-45909c67741fd9d8f6aaccdd402721cb042fe080.tar.gz
ports-45909c67741fd9d8f6aaccdd402721cb042fe080.zip
devel/stuffbin: New port: Compress and embed static files and assets into Go binaries
-rw-r--r--devel/Makefile1
-rw-r--r--devel/stuffbin/Makefile26
-rw-r--r--devel/stuffbin/distinfo5
-rw-r--r--devel/stuffbin/pkg-descr7
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index da32000c64b2..feaab76dd9b8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6947,6 +6947,7 @@
SUBDIR += strace
SUBDIR += string_theory
SUBDIR += stringencoders
+ SUBDIR += stuffbin
SUBDIR += stxxl
SUBDIR += subversion
SUBDIR += subversion-book
diff --git a/devel/stuffbin/Makefile b/devel/stuffbin/Makefile
new file mode 100644
index 000000000000..6b888c37dfd3
--- /dev/null
+++ b/devel/stuffbin/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= stuffbin
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+CATEGORIES= devel
+
+MAINTAINER= lcook@FreeBSD.org
+COMMENT= Compress and embed static files and assets into Go binaries
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+GO_MODULE= github.com/knadh/${PORTNAME}
+GO_TARGET= ./${PORTNAME}:${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/stuffbin/distinfo b/devel/stuffbin/distinfo
new file mode 100644
index 000000000000..f7102cab8245
--- /dev/null
+++ b/devel/stuffbin/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1631287902
+SHA256 (go/devel_stuffbin/stuffbin-v1.1.0/v1.1.0.mod) = 9d6d9f4e36cee45dbdbf23cc74248386b01dac85f77146e26493d732740dfe9a
+SIZE (go/devel_stuffbin/stuffbin-v1.1.0/v1.1.0.mod) = 42
+SHA256 (go/devel_stuffbin/stuffbin-v1.1.0/v1.1.0.zip) = 4257e94899b069ce09cb74c6a5758a13721531de7344517c904b43ffc9778ad8
+SIZE (go/devel_stuffbin/stuffbin-v1.1.0/v1.1.0.zip) = 15483
diff --git a/devel/stuffbin/pkg-descr b/devel/stuffbin/pkg-descr
new file mode 100644
index 000000000000..66f1833dda4f
--- /dev/null
+++ b/devel/stuffbin/pkg-descr
@@ -0,0 +1,7 @@
+Utility to compress and embed static files and
+assets into Go binaries for distribution. It
+supports falling back to the local file system
+when no embedded assets are available, for
+instance, in development mode.
+
+WWW: https://github.com/knadh/stuffbin