aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-07-09 15:12:36 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-07-09 15:13:50 +0000
commit460d8f3ed294b7cf3cca1e4e2c0b744e529d7cc1 (patch)
treea9477db53e3e484a8d038c0e9f3b5aded021be85
parentd5419d117e201ccc16c608a16e06dac6aea2ddbd (diff)
downloadports-460d8f3ed294b7cf3cca1e4e2c0b744e529d7cc1.tar.gz
ports-460d8f3ed294b7cf3cca1e4e2c0b744e529d7cc1.zip
sysutils/linuxfdisk: remove bogus ONLY_FOR_ARCHS limitation
There is hardly anything really architecture-specific about the disk management program. It was marked as working correctly only on i386 in 17b931398cd8 back in 2003 without any explanation (albeit the phrase "bento via kris" suggests that it could be a build failure on the cluster) by abusing ONLY_FOR_ARCHS, which had only been added to since then. While here, prefer ATA to IDE when talking to a user as nowadays IDE falls out of common lexicon and means PATA disks particularly.
-rw-r--r--sysutils/linuxfdisk/Makefile1
-rw-r--r--sysutils/linuxfdisk/files/patch-FreeBSD11
2 files changed, 6 insertions, 6 deletions
diff --git a/sysutils/linuxfdisk/Makefile b/sysutils/linuxfdisk/Makefile
index 0f15ed8c1747..66fdf9323d9f 100644
--- a/sysutils/linuxfdisk/Makefile
+++ b/sysutils/linuxfdisk/Makefile
@@ -16,7 +16,6 @@ LICENSE= GPLv2+
WRKSRC= ${WRKDIR}/util-linux-${PORTVERSION}/fdisk
USES= tar:bzip2
-ONLY_FOR_ARCHS= i386 amd64 armv7 powerpc powerpc64 powerpc64le
pre-patch:
@${CP} ${FILESDIR}/linuxfdisk-Makefile ${WRKSRC}/Makefile
diff --git a/sysutils/linuxfdisk/files/patch-FreeBSD b/sysutils/linuxfdisk/files/patch-FreeBSD
index 4885c5491eac..130d5fca5451 100644
--- a/sysutils/linuxfdisk/files/patch-FreeBSD
+++ b/sysutils/linuxfdisk/files/patch-FreeBSD
@@ -243,7 +243,7 @@ diff -rNu fdisk.c fdisk.c
-" or: fdisk /dev/eda (for the first PS/2 ESDI drive)\n"
-" or: fdisk /dev/rd/c0d0 or: fdisk /dev/ida/c0d0 (for RAID devices)\n"
+"Usage: fdisk-linux [-l] [-b SSZ] [-u] device\n"
-+"E.g.: fdisk-linux /dev/ada0 (for the first IDE disk)\n"
++"E.g.: fdisk-linux /dev/ada0 (for the first ATA disk)\n"
+" or: fdisk-linux /dev/da2 (for the third SCSI disk)\n"
" ...\n");
break;
@@ -950,7 +950,7 @@ diff -rNu fdisk.8 fdisk.8
.fi
-(/dev/hd[a-h] for IDE disks, /dev/sd[a-p] for SCSI disks,
-/dev/ed[a-d] for ESDI disks, /dev/xd[ab] for XT disks).
-+(/dev/adaN for IDE disks, /dev/daN for SCSI disks, N=0,1,2...)
++(/dev/adaN for ATA disks, /dev/daN for SCSI disks, N=0,1,2...)
A device name refers to the entire disk.
The
@@ -959,12 +959,13 @@ diff -rNu fdisk.8 fdisk.8
.I device
-name followed by a partition number. For example,
-.B /dev/hda1
-+name followed by 's' and a partition number. For example,
-+.B /dev/ada0s1
- is the first partition on the first IDE hard disk in the system.
+-is the first partition on the first IDE hard disk in the system.
-IDE disks can have up to 63 partitions, SCSI disks up to 15.
-See also
-.IR /usr/src/linux/Documentation/devices.txt .
++name followed by 's' and a partition number. For example,
++.B /dev/ada0s1
++is the first partition on the first ATA hard disk in the system.
A BSD/SUN type disklabel can describe 8 partitions,
the third of which should be a `whole disk' partition.