aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-10-21 16:28:16 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-07-01 13:50:16 +0000
commit465768e9a10183d02bc4dd609f95667ed777c6ed (patch)
tree18051cfdc14fa074fce2860c1e5575988b539b50
parent09b9b34473ac7efae714589e296510a3d9ac8a19 (diff)
downloadports-465768e9a10183d02bc4dd609f95667ed777c6ed.tar.gz
ports-465768e9a10183d02bc4dd609f95667ed777c6ed.zip
graphics/libliftoff: add new port
libliftoff eases the use of KMS planes from userspace without standing in your way. Users create "virtual planes" called layers, set KMS properties on them, and libliftoff will pick planes for these layers if possible. https://github.com/emersion/libliftoff
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libliftoff/Makefile19
-rw-r--r--graphics/libliftoff/distinfo3
-rw-r--r--graphics/libliftoff/pkg-descr6
-rw-r--r--graphics/libliftoff/pkg-plist5
5 files changed, 34 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f809b7d1d394..1f97271abb6b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -465,6 +465,7 @@
SUBDIR += libkexiv2
SUBDIR += libkipi
SUBDIR += libksane
+ SUBDIR += libliftoff
SUBDIR += liblqr-1
SUBDIR += liblug
SUBDIR += libmng
diff --git a/graphics/libliftoff/Makefile b/graphics/libliftoff/Makefile
new file mode 100644
index 000000000000..1fe29b852c25
--- /dev/null
+++ b/graphics/libliftoff/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= libliftoff
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.0
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Lightweight KMS plane library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libdrm.so:graphics/libdrm
+
+USES= compiler:c11 meson pkgconfig
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+GH_ACCOUNT= emersion
+
+.include <bsd.port.mk>
diff --git a/graphics/libliftoff/distinfo b/graphics/libliftoff/distinfo
new file mode 100644
index 000000000000..1c810531efd8
--- /dev/null
+++ b/graphics/libliftoff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625142893
+SHA256 (emersion-libliftoff-v0.1.0_GH0.tar.gz) = 7a88e565b560e2c714a3606e9e03edbdc4dba3255d7fa4a0db4f5ab4975c5a9f
+SIZE (emersion-libliftoff-v0.1.0_GH0.tar.gz) = 29614
diff --git a/graphics/libliftoff/pkg-descr b/graphics/libliftoff/pkg-descr
new file mode 100644
index 000000000000..841208fd1aba
--- /dev/null
+++ b/graphics/libliftoff/pkg-descr
@@ -0,0 +1,6 @@
+libliftoff eases the use of KMS planes from userspace without standing
+in your way. Users create "virtual planes" called layers, set KMS
+properties on them, and libliftoff will pick planes for these layers
+if possible.
+
+WWW: https://github.com/emersion/libliftoff
diff --git a/graphics/libliftoff/pkg-plist b/graphics/libliftoff/pkg-plist
new file mode 100644
index 000000000000..3cc1cc500c35
--- /dev/null
+++ b/graphics/libliftoff/pkg-plist
@@ -0,0 +1,5 @@
+include/libliftoff.h
+lib/libliftoff.so
+lib/libliftoff.so.0
+lib/libliftoff.so.0.1.0
+libdata/pkgconfig/libliftoff.pc