aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-06-28 20:41:41 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-06-28 20:41:41 +0000
commit46888d1f6606ae9f70527a800cdca880a78a453e (patch)
tree2cd5443162bb6b04cc8818d89c4e146f3ca419b6
parent11e7e27b3c4748405e0ed0573904d56f4d37cc16 (diff)
downloadports-46888d1f6606ae9f70527a800cdca880a78a453e.tar.gz
ports-46888d1f6606ae9f70527a800cdca880a78a453e.zip
deskutils/easystroke: Improve fix for clang 16
Properly fix the code instead of just disabling the error message.
-rw-r--r--deskutils/easystroke/Makefile1
-rw-r--r--deskutils/easystroke/files/patch-cellrenderertextish.c20
2 files changed, 20 insertions, 1 deletions
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
index 28dfce6fe133..7d0aaaede028 100644
--- a/deskutils/easystroke/Makefile
+++ b/deskutils/easystroke/Makefile
@@ -23,7 +23,6 @@ USES= compiler:c++11-lang gettext-tools gmake gnome pkgconfig xorg
USE_GNOME= gtkmm30 intltool
USE_XORG= x11 xext xfixes xi xtst
USE_CXXSTD= c++11
-CFLAGS= -Wno-error=incompatible-function-pointer-types
USE_GITHUB= yes
GH_ACCOUNT= thjaeger
diff --git a/deskutils/easystroke/files/patch-cellrenderertextish.c b/deskutils/easystroke/files/patch-cellrenderertextish.c
new file mode 100644
index 000000000000..773622310ab7
--- /dev/null
+++ b/deskutils/easystroke/files/patch-cellrenderertextish.c
@@ -0,0 +1,20 @@
+--- cellrenderertextish.c.orig 2016-07-05 18:32:44 UTC
++++ cellrenderertextish.c
+@@ -154,7 +154,7 @@ static gchar** _vala_array_dup1 (gchar** self, int len
+ CellRendererTextish* cell_renderer_textish_new_with_items (gchar** items, int items_length1);
+ CellRendererTextish* cell_renderer_textish_construct_with_items (GType object_type, gchar** items, int items_length1);
+ static gchar** _vala_array_dup1 (gchar** self, int length);
+-static GtkCellEditable* cell_renderer_textish_real_start_editing (GtkCellRenderer* base, GdkEvent* event, GtkWidget* widget, const gchar* path, GdkRectangle* background_area, GdkRectangle* cell_area, GtkCellRendererState flags);
++static GtkCellEditable* cell_renderer_textish_real_start_editing (GtkCellRenderer* base, GdkEvent* event, GtkWidget* widget, const gchar* path, const GdkRectangle* background_area, const GdkRectangle* cell_area, GtkCellRendererState flags);
+ CellEditableAccel* cell_editable_accel_new (CellRendererTextish* parent, const gchar* path, GtkWidget* widget);
+ CellEditableAccel* cell_editable_accel_construct (GType object_type, CellRendererTextish* parent, const gchar* path, GtkWidget* widget);
+ GType cell_editable_accel_get_type (void) G_GNUC_CONST;
+@@ -282,7 +282,7 @@ static gpointer _g_object_ref0 (gpointer self) {
+ }
+
+
+-static GtkCellEditable* cell_renderer_textish_real_start_editing (GtkCellRenderer* base, GdkEvent* event, GtkWidget* widget, const gchar* path, GdkRectangle* background_area, GdkRectangle* cell_area, GtkCellRendererState flags) {
++static GtkCellEditable* cell_renderer_textish_real_start_editing (GtkCellRenderer* base, GdkEvent* event, GtkWidget* widget, const gchar* path, const GdkRectangle* background_area, const GdkRectangle* cell_area, GtkCellRendererState flags) {
+ CellRendererTextish * self;
+ GtkCellEditable* result = NULL;
+ gboolean _tmp0_ = FALSE;