aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-08-03 15:19:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-08-03 15:20:48 +0000
commit46ba65cae81e63eede6ea176245e27110e37cfd5 (patch)
tree745a523b1d1d8efc84e31b1d7acb46dd74023f65
parent2acdadaf097598eb951c388eee94a1b1c555c802 (diff)
downloadports-46ba65cae81e63eede6ea176245e27110e37cfd5.tar.gz
ports-46ba65cae81e63eede6ea176245e27110e37cfd5.zip
devel/muon: new port
Meson compatible build system written in c99
-rw-r--r--devel/Makefile1
-rw-r--r--devel/muon/Makefile36
-rw-r--r--devel/muon/distinfo3
-rw-r--r--devel/muon/pkg-descr18
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 87a4102790b4..6857610b80d2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1539,6 +1539,7 @@
SUBDIR += mspdebug
SUBDIR += mstch
SUBDIR += mtbl
+ SUBDIR += muon
SUBDIR += mustache
SUBDIR += mutagen
SUBDIR += myrepos
diff --git a/devel/muon/Makefile b/devel/muon/Makefile
new file mode 100644
index 000000000000..0713b2cbaba2
--- /dev/null
+++ b/devel/muon/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= muon
+PORTVERSION= 0.0.1.p1
+CATEGORIES= devel
+MASTER_SITES= https://git.sr.ht/~lattis/muon/archive/
+DISTNAME= b44e90f
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Build system compatible with meson
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= ninja pkgconfig
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTNAME}
+BUILD_WRKSRC= ${WRKSRC}/_build
+INSTALL_WRKSRC= ${WRKSRC}/_build
+
+ALL_TARGET=
+PLIST_FILES= bin/muon \
+ share/man/man1/muon.1.gz \
+ share/man/man5/meson.build.5.gz
+
+post-patch:
+# this confuses some of the FreeBSD configure targets
+ @${RM} -r ${WRKSRC}/tests/project/common
+
+do-configure:
+ @(cd ${WRKSRC} && \
+ ${SH} bootstrap.sh && \
+ ./muon setup -Dlibcurl=disabled -Dlibarchive=disabled ${BUILD_WRKSRC})
+
+do-install:
+ @(${SETENV} ${MAKE_ENV} ${BUILD_WRKSRC}/muon -C ${BUILD_WRKSRC} install)
+
+.include <bsd.port.mk>
diff --git a/devel/muon/distinfo b/devel/muon/distinfo
new file mode 100644
index 000000000000..25d52fb3e3d9
--- /dev/null
+++ b/devel/muon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659537739
+SHA256 (b44e90f.tar.gz) = 926d5de4b4cee8ca047168d0611824081a982592349bc2fb0ddb99bcee07f79b
+SIZE (b44e90f.tar.gz) = 442889
diff --git a/devel/muon/pkg-descr b/devel/muon/pkg-descr
new file mode 100644
index 000000000000..3785f6c7d51e
--- /dev/null
+++ b/devel/muon/pkg-descr
@@ -0,0 +1,18 @@
+muon is an implementation of the meson build system in c99 with minimal
+dependencies.
+
+# Non-features
+* bug-for-bug compatibility with meson. In fact, muon aspires to be stricter
+ than meson in cases where meson's implementation seems error prone. muon uses
+ the official meson documentation as its specification.
+* cli compatibility with meson. muon has different flags, subcommands, etc., and
+ should not be renamed/symlinked to meson.
+
+# Features
+* muon analyze - a static analyzer for meson.build files. Capable of doing type
+ inference, checking unused variables, undeclared variables, etc.
+* muon fmt_unstable - a meson.build code formatter
+* An interactive stepping debugger with the dbg() function.
+* Fast
+
+WWW: https://muon.build/