aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-04-10 19:53:55 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-04-19 16:52:58 +0000
commit470588767922265e085a431f87286f729f92ac4f (patch)
tree8c42a102e8a47893b3842df72c19522bb50e66c8
parenta1141279a7ee08e64f613902751272d216ce29e5 (diff)
downloadports-470588767922265e085a431f87286f729f92ac4f.tar.gz
ports-470588767922265e085a431f87286f729f92ac4f.zip
x11-toolkits/gtk-session-lock: add new port
This is a library to use GTK 3 to build screen lockers using the secure ext-session-lock-v1 protocol. This Library is compatible with C, C++ and any language that supports GObject introspection files (Python, Vala, etc, see using the library below). This library is a fork of the incredible gtk-layer-shell, which has laid all the groundwork necessary to make this happen. https://github.com/Cu3PO42/gtk-session-lock
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/gtk-session-lock/Makefile24
-rw-r--r--x11-toolkits/gtk-session-lock/distinfo3
-rw-r--r--x11-toolkits/gtk-session-lock/pkg-descr7
-rw-r--r--x11-toolkits/gtk-session-lock/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 8ae4dc9bb9a5..31fdfdbb82fe 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -24,6 +24,7 @@
SUBDIR += gstreamer1-plugins-gtk
SUBDIR += gstreamer1-plugins-pango
SUBDIR += gtk-layer-shell
+ SUBDIR += gtk-session-lock
SUBDIR += gtk-sharp-beans
SUBDIR += gtk-sharp20
SUBDIR += gtk-sharp30
diff --git a/x11-toolkits/gtk-session-lock/Makefile b/x11-toolkits/gtk-session-lock/Makefile
new file mode 100644
index 000000000000..778d6394cc03
--- /dev/null
+++ b/x11-toolkits/gtk-session-lock/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= gtk-session-lock
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.0
+CATEGORIES= x11-toolkits
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= GTK Session Lock for GTK3
+WWW= https://github.com/Cu3PO42/gtk-session-lock
+
+LICENSE= GPLv3+ MIT
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv3+ = ${WRKSRC}/LICENSE_GPL.txt
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE_MIT.txt
+
+BUILD_DEPENDS= wayland-protocols>=1.16:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gnome meson pkgconfig vala:build
+USE_GNOME= gtk30 introspection:build
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+GH_ACCOUNT= Cu3PO42
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk-session-lock/distinfo b/x11-toolkits/gtk-session-lock/distinfo
new file mode 100644
index 000000000000..ae2d5d38132f
--- /dev/null
+++ b/x11-toolkits/gtk-session-lock/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1712778835
+SHA256 (Cu3PO42-gtk-session-lock-v0.2.0_GH0.tar.gz) = a4245c6930580c15ed263b9a7bb7e39f47693baec78be1026b4e0e28b233cb4e
+SIZE (Cu3PO42-gtk-session-lock-v0.2.0_GH0.tar.gz) = 96770
diff --git a/x11-toolkits/gtk-session-lock/pkg-descr b/x11-toolkits/gtk-session-lock/pkg-descr
new file mode 100644
index 000000000000..0bbe84667cd9
--- /dev/null
+++ b/x11-toolkits/gtk-session-lock/pkg-descr
@@ -0,0 +1,7 @@
+This is a library to use GTK 3 to build screen lockers using the
+secure ext-session-lock-v1 protocol. This Library is compatible with
+C, C++ and any language that supports GObject introspection files
+(Python, Vala, etc, see using the library below).
+
+This library is a fork of the incredible gtk-layer-shell, which has
+laid all the groundwork necessary to make this happen.
diff --git a/x11-toolkits/gtk-session-lock/pkg-plist b/x11-toolkits/gtk-session-lock/pkg-plist
new file mode 100644
index 000000000000..7732a8c49170
--- /dev/null
+++ b/x11-toolkits/gtk-session-lock/pkg-plist
@@ -0,0 +1,9 @@
+include/gtk-session-lock/gtk-session-lock.h
+lib/girepository-1.0/GtkSessionLock-0.1.typelib
+lib/libgtk-session-lock.so
+lib/libgtk-session-lock.so.0
+lib/libgtk-session-lock.so.0.2.0
+libdata/pkgconfig/gtk-session-lock-0.pc
+share/gir-1.0/GtkSessionLock-0.1.gir
+share/vala/vapi/gtk-session-lock-0.deps
+share/vala/vapi/gtk-session-lock-0.vapi