aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-03-22 04:02:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-03-22 04:02:27 +0000
commit471d29fc25d0c664931c0dfe005f07769bb48ca5 (patch)
tree6faed1f322dd0ad239bf79a74c1c32a454cb0961
parent4719d1e11f5e300f686b174cf6ca9baf5c20e1b0 (diff)
downloadports-471d29fc25d0c664931c0dfe005f07769bb48ca5.tar.gz
ports-471d29fc25d0c664931c0dfe005f07769bb48ca5.zip
misc/py-openai-whisper: New port: Robust Speech Recognition via Large-Scale Weak Supervision
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-openai-whisper/Makefile33
-rw-r--r--misc/py-openai-whisper/distinfo3
-rw-r--r--misc/py-openai-whisper/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 6ef2c99c1ff5..75b1f28a5c61 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -450,6 +450,7 @@
SUBDIR += py-onnx
SUBDIR += py-onnx-tf
SUBDIR += py-openai
+ SUBDIR += py-openai-whisper
SUBDIR += py-openpaperwork-core
SUBDIR += py-openpaperwork-gtk
SUBDIR += py-openvdb
diff --git a/misc/py-openai-whisper/Makefile b/misc/py-openai-whisper/Makefile
new file mode 100644
index 000000000000..a8e1f4dbc882
--- /dev/null
+++ b/misc/py-openai-whisper/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= openai-whisper
+DISTVERSIONPREFIX= v
+DISTVERSION= 20231117
+CATEGORIES= misc python # machine-learning
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Robust Speech Recognition via Large-Scale Weak Supervision
+WWW= https://openai.com/research/whisper
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numba>0:devel/py-numba@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tiktoken>=0:textproc/py-tiktoken@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytorch>=0:misc/py-pytorch@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest # tests use 4+ GB each, several tests fail
+
+USE_GITHUB= yes
+GH_ACCOUNT= openai
+GH_PROJECT= whisper
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-openai-whisper/distinfo b/misc/py-openai-whisper/distinfo
new file mode 100644
index 000000000000..9cf8b2cb969b
--- /dev/null
+++ b/misc/py-openai-whisper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1711013814
+SHA256 (openai-whisper-v20231117_GH0.tar.gz) = b0f8b8d3b485fad2c423ba7f8b95eded067aad11ed3165828aad819d168cac06
+SIZE (openai-whisper-v20231117_GH0.tar.gz) = 7261054
diff --git a/misc/py-openai-whisper/pkg-descr b/misc/py-openai-whisper/pkg-descr
new file mode 100644
index 000000000000..c448226b1e34
--- /dev/null
+++ b/misc/py-openai-whisper/pkg-descr
@@ -0,0 +1,4 @@
+Whisper is a general-purpose speech recognition model. It is trained on a large
+dataset of diverse audio and is also a multitasking model that can perform
+multilingual speech recognition, speech translation, and language
+identification.