aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-30 15:56:04 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-30 15:56:04 +0000
commit474d52ab8b0dbe2012b70fcdafea2883d99b00db (patch)
tree2977e0429a640490737b75642012b0164b5ec221
parentf8582cb889d535e13d4519d9e83993e878d9b9f1 (diff)
downloadports-474d52ab8b0dbe2012b70fcdafea2883d99b00db.tar.gz
ports-474d52ab8b0dbe2012b70fcdafea2883d99b00db.zip
devel/py-hatchling: Add py-hatchling 0.24.0
Hatchling is the extensible, standards compliant build backend used by Hatch. WWW: https://github.com/ofek/hatch/tree/master/backend
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hatchling/Makefile42
-rw-r--r--devel/py-hatchling/distinfo3
-rw-r--r--devel/py-hatchling/files/setup.py68
-rw-r--r--devel/py-hatchling/pkg-descr3
5 files changed, 117 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 68f7ea9a6721..a7725a4b49c1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4611,6 +4611,7 @@
SUBDIR += py-gyp
SUBDIR += py-hash_ring
SUBDIR += py-hatch
+ SUBDIR += py-hatchling
SUBDIR += py-heapdict
SUBDIR += py-helpdev
SUBDIR += py-hg-evolve
diff --git a/devel/py-hatchling/Makefile b/devel/py-hatchling/Makefile
new file mode 100644
index 000000000000..ec70b667c54a
--- /dev/null
+++ b/devel/py-hatchling/Makefile
@@ -0,0 +1,42 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= hatchling
+PORTVERSION= 0.24.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Modern, extensible Python build backend
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+xBUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}editables>=0.3:devel/py-editables@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pathspec>=0.9:devel/py-pathspec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pluggy>=1.0.0:devel/py-pluggy@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}editables>=0.3:devel/py-editables@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pathspec>=0.9:devel/py-pathspec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pluggy>=1.0.0:devel/py-pluggy@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
+.endif
+
+.if ${PYTHON_REL} < 31100
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=1.2.2:textproc/py-tomli@${PY_FLAVOR}
+.endif
+
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-hatchling/distinfo b/devel/py-hatchling/distinfo
new file mode 100644
index 000000000000..b3b48317f2f6
--- /dev/null
+++ b/devel/py-hatchling/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651316567
+SHA256 (hatchling-0.24.0.tar.gz) = ce6765f5b5baf3cb57d2f80196c50e201e3728cacd95353f5c9b4f03dfdf4eb9
+SIZE (hatchling-0.24.0.tar.gz) = 44544
diff --git a/devel/py-hatchling/files/setup.py b/devel/py-hatchling/files/setup.py
new file mode 100644
index 000000000000..c10b93cfc790
--- /dev/null
+++ b/devel/py-hatchling/files/setup.py
@@ -0,0 +1,68 @@
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+setup(
+ name='hatchling',
+ version='%%PORTVERSION%%',
+ description='Modern, extensible Python build backend',
+ long_description='# Hatchling\n\n-----\n\nThis is the extensible, standards compliant build backend used by [Hatch](https://github.com/ofek/hatch).\n',
+ author_email='Ofek Lev <oss@ofek.dev>',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Topic :: Software Development :: Build Tools',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+ install_requires=[
+ 'editables>=0.3; python_version > "3"',
+ 'importlib-metadata; python_version < "3.8"',
+ 'packaging>=21.3; python_version > "3"',
+ 'packaging~=20.9; python_version < "3"',
+ 'pathspec>=0.9',
+ 'pluggy>=1.0.0; python_version > "3"',
+ 'pluggy~=0.13; python_version < "3"',
+ 'tomli>=1.2.2; python_version > "3" and python_version < "3.11"',
+ 'toml~=0.10.2; python_version < "3"',
+ ],
+ entry_points={
+ 'console_scripts': [
+ 'hatchling = hatchling.cli:hatchling',
+ ],
+ },
+ packages=[
+ 'hatchling',
+ 'hatchling.bridge',
+ 'hatchling.builders',
+ 'hatchling.builders.hooks',
+ 'hatchling.builders.hooks.plugin',
+ 'hatchling.builders.plugin',
+ 'hatchling.cli',
+ 'hatchling.cli.build',
+ 'hatchling.cli.dep',
+ 'hatchling.cli.version',
+ 'hatchling.dep',
+ 'hatchling.licenses',
+ 'hatchling.metadata',
+ 'hatchling.metadata.plugin',
+ 'hatchling.plugin',
+ 'hatchling.utils',
+ 'hatchling.version',
+ 'hatchling.version.scheme',
+ 'hatchling.version.scheme.plugin',
+ 'hatchling.version.source',
+ 'hatchling.version.source.plugin',
+ ],
+ package_dir={
+ '': 'src',
+ },
+)
diff --git a/devel/py-hatchling/pkg-descr b/devel/py-hatchling/pkg-descr
new file mode 100644
index 000000000000..95368c6a87d3
--- /dev/null
+++ b/devel/py-hatchling/pkg-descr
@@ -0,0 +1,3 @@
+Hatchling is the extensible, standards compliant build backend used by Hatch.
+
+WWW: https://github.com/ofek/hatch/tree/master/backend