aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-11-11 09:45:42 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-11-12 13:47:23 +0000
commit47b36994fd5809d63b7d365016b193dc129b6aca (patch)
tree81b0cbde4ffd539fb2ff7588a456990a0778d615
parent173683a2d0f477fd7457a3b3d2e1d065dd252bda (diff)
downloadports-47b36994fd5809d63b7d365016b193dc129b6aca.tar.gz
ports-47b36994fd5809d63b7d365016b193dc129b6aca.zip
devel/ittapi: new port, Intel ITT and JIT API
ATM it is bundled in Julia.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ittapi/Makefile25
-rw-r--r--devel/ittapi/distinfo3
-rw-r--r--devel/ittapi/pkg-descr12
-rw-r--r--devel/ittapi/pkg-plist11
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c72b6c82a2b0..72e4ff3d0821 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1030,6 +1030,7 @@
SUBDIR += isfreedesktop
SUBDIR += isl
SUBDIR += ispc
+ SUBDIR += ittapi
SUBDIR += ivykis
SUBDIR += jam
SUBDIR += jansson
diff --git a/devel/ittapi/Makefile b/devel/ittapi/Makefile
new file mode 100644
index 000000000000..44636dc01ce0
--- /dev/null
+++ b/devel/ittapi/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= ittapi
+PORTVERSION= 3.24.3
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Instrumentation and Tracing Technology and Just-In-Time API
+WWW= https://github.com/intel/ittapi
+
+LICENSE= BSD3CLAUSE GPLv2
+LICENSE_COMB= dual
+LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/LICENSES/BSD-3-Clause.txt
+LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSES/GPL-2.0-only.txt
+
+USE_GITHUB= yes
+GH_ACCOUNT= intel
+
+USES= cmake
+CMAKE_ARGS= -DITT_API_IPT_SUPPORT:BOOL=ON
+
+# Note: Rust support is not yet enabled in this port
+OPTIONS_DEFINE= FORTRAN
+FORTRAN_CMAKE_BOOL= ITT_API_FORTRAN_SUPPORT
+
+.include <bsd.port.mk>
diff --git a/devel/ittapi/distinfo b/devel/ittapi/distinfo
new file mode 100644
index 000000000000..97d2f81fc51a
--- /dev/null
+++ b/devel/ittapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1699653045
+SHA256 (intel-ittapi-v3.24.3_GH0.tar.gz) = cf5903c1bf5c13bc808a04f2d7624eef064f44e76669688f779ebb8d26e9911f
+SIZE (intel-ittapi-v3.24.3_GH0.tar.gz) = 246256
diff --git a/devel/ittapi/pkg-descr b/devel/ittapi/pkg-descr
new file mode 100644
index 000000000000..3af47df703c7
--- /dev/null
+++ b/devel/ittapi/pkg-descr
@@ -0,0 +1,12 @@
+This ITT/JIT open source profiling API includes:
+
+- Instrumentation and Tracing Technology (ITT) API
+- Just-In-Time (JIT) Profiling API
+
+The Instrumentation and Tracing Technology (ITT) API enables your application to
+generate and control the collection of trace data during its execution across
+different Intel tools.
+
+ITT API consists of two parts: a static part and a dynamic part. The dynamic
+part is specific for a tool and distributed only with a particular tool. The
+static part is a common part shared between tools.
diff --git a/devel/ittapi/pkg-plist b/devel/ittapi/pkg-plist
new file mode 100644
index 000000000000..7800df035406
--- /dev/null
+++ b/devel/ittapi/pkg-plist
@@ -0,0 +1,11 @@
+include/advisor-annotate.h
+include/ittnotify-zca.h
+include/ittnotify.h
+include/jitprofiling.h
+include/legacy/ittnotify.h
+include/libittnotify.h
+lib/cmake/ittapi/ittapi-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ittapi/ittapi-targets.cmake
+lib/cmake/ittapi/ittapiConfig.cmake
+lib/cmake/ittapi/ittapiConfigVersion.cmake
+lib/libittnotify.a