aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-04-19 08:06:18 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-04-19 08:34:38 +0000
commit47c4c901458758f40f67554212a301fdb8045ff6 (patch)
tree9bce10986103a2fae78b16155e7af4b1c191bf37
parentc9d13b150bf209302fbc8f6308ca89411f4d3a44 (diff)
downloadports-47c4c901458758f40f67554212a301fdb8045ff6.tar.gz
ports-47c4c901458758f40f67554212a301fdb8045ff6.zip
net/unison251: Try to fix build failure due to race condition in Makefile
PR: 263067 MFH: 2022Q2 (cherry picked from commit c46c155b02df4d51fc6e5868fb151918b0a07cc5)
-rw-r--r--net/unison251/files/patch-Makefile.OCaml19
1 files changed, 15 insertions, 4 deletions
diff --git a/net/unison251/files/patch-Makefile.OCaml b/net/unison251/files/patch-Makefile.OCaml
index 45859e189c5a..147a3793331a 100644
--- a/net/unison251/files/patch-Makefile.OCaml
+++ b/net/unison251/files/patch-Makefile.OCaml
@@ -1,6 +1,6 @@
---- Makefile.OCaml.orig 2021-06-23 14:30:30 UTC
+--- Makefile.OCaml.orig 2021-12-18 15:04:56 UTC
+++ Makefile.OCaml
-@@ -34,7 +34,11 @@ ifeq ($(shell uname),OpenBSD)
+@@ -34,7 +34,11 @@ ifeq ($(shell uname),NetBSD)
else
ifeq ($(shell uname),NetBSD)
OSARCH=NetBSD
@@ -12,7 +12,7 @@
ifeq ($(shell uname),Linux)
OSARCH=Linux
endif
-@@ -290,6 +294,11 @@ ifeq ($(OSARCH),Linux)
+@@ -301,6 +305,11 @@ endif
INCLFLAGS+=-I fsmonitor -I fsmonitor/linux
endif
@@ -24,7 +24,18 @@
ifeq ($(OSARCH),solaris)
-include fsmonitor/solaris/Makefile src/fsmonitor/solaris/Makefile
INCLFLAGS+=-I fsmonitor -I fsmonitor/solaris
-@@ -432,7 +441,7 @@ fswatch.cmi : ubase/prefs.cmi
+@@ -427,6 +436,10 @@ win32rc/unison.res.lib: win32rc/unison.res
+ -$(RM) $@
+ ocamllex $<
+
++compat%.cmi: compat%.mli
++ @echo "$(CAMLC): $< ---> $@"
++ $(CAMLC) $(CAMLFLAGS) $(COMPATCAMLFLAGS) -c $(CWD)/$<
++
+ %.cmi : %.mli
+ @echo "$(CAMLC): $< ---> $@"
+ $(CAMLC) $(CAMLFLAGS) $(COMPATCAMLFLAGS) -c $(CWD)/$<
+@@ -451,7 +464,7 @@ compat%.cmx: compat%.ml
%.o %.obj: %.c
@echo "$(CAMLC): $< ---> $@"