aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRozhuk Ivan <rozhuk.im@gmail.com>2022-12-13 01:12:57 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2022-12-16 01:44:49 +0000
commit47cc96f7fe91bd63dbe6e46026161454d9e59f34 (patch)
tree4229d8658e09ba244f51da16bea336dd281fa7e2
parent65404737e11e58da1fd7a4113296c259c7a48ef0 (diff)
downloadports-47cc96f7fe91bd63dbe6e46026161454d9e59f34.tar.gz
ports-47cc96f7fe91bd63dbe6e46026161454d9e59f34.zip
security/gostsum: New port:Implementation of GOST R 34.11-94, GOST R 34.11-2012 hash functions
PR: 268343
-rw-r--r--security/Makefile1
-rw-r--r--security/gostsum/Makefile28
-rw-r--r--security/gostsum/distinfo3
-rw-r--r--security/gostsum/pkg-descr2
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 616591b13233..b596c0ee9ce6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -183,6 +183,7 @@
SUBDIR += gopass
SUBDIR += gorilla
SUBDIR += gost-engine
+ SUBDIR += gostsum
SUBDIR += gpa
SUBDIR += gpg-gui
SUBDIR += gpg-tui
diff --git a/security/gostsum/Makefile b/security/gostsum/Makefile
new file mode 100644
index 000000000000..5d14ce027b94
--- /dev/null
+++ b/security/gostsum/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= gostsum
+PORTVERSION= 20221213
+CATEGORIES= security
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Implementation of GOST R 34.11-94, GOST R 34.11-2012 hash functions
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= AnatolyGeorgievski
+GH_TAGNAME= b1a7a8e33ade59d43147a2f2531fe87c26de4093
+
+PLIST_FILES= bin/gostsum
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC =.*||g' \
+ -e 's|CFLAGS =.*||g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gostsum ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/gostsum/distinfo b/security/gostsum/distinfo
new file mode 100644
index 000000000000..89b08482b88c
--- /dev/null
+++ b/security/gostsum/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1670990367
+SHA256 (AnatolyGeorgievski-gostsum-20221213-b1a7a8e33ade59d43147a2f2531fe87c26de4093_GH0.tar.gz) = bd542fd6f030573a5e6c36975f0dd6fb901fdae529f5aaf063e0fbb3d48d89b5
+SIZE (AnatolyGeorgievski-gostsum-20221213-b1a7a8e33ade59d43147a2f2531fe87c26de4093_GH0.tar.gz) = 90968
diff --git a/security/gostsum/pkg-descr b/security/gostsum/pkg-descr
new file mode 100644
index 000000000000..78a826faa521
--- /dev/null
+++ b/security/gostsum/pkg-descr
@@ -0,0 +1,2 @@
+Implementation of GOST R 34.11-94, GOST R 34.11-2012 (STRIBOG-256/512),
+SHA, SHA2 hash functions and hash based algorithms: HMAC, PBKDF, SSHA.