aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2024-06-04 15:09:42 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2024-06-04 15:14:28 +0000
commit482b5137ce1ecb52784c7f07f8ae3e6cb61ae8e1 (patch)
treee11927028047adbe84ed4529b43af80006ee60f5
parent3c63d93eaee1efcc858ffcf00181a525ad787019 (diff)
downloadports-482b5137ce1ecb52784c7f07f8ae3e6cb61ae8e1.tar.gz
ports-482b5137ce1ecb52784c7f07f8ae3e6cb61ae8e1.zip
www/nginx-devel: fix third-party passenger module warning
Also, release third-party passenger module from the pcre1 users list, it builds fine with pcre2. Bump PORTREVISION.
-rw-r--r--www/nginx-devel/Makefile4
-rw-r--r--www/nginx-devel/files/extra-patch-passenger_src_nginx__module_Configuration.c24
2 files changed, 22 insertions, 6 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index cdc155fdca37..27f1376a5f8c 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME?= nginx
PORTVERSION= 1.27.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
@@ -244,7 +244,7 @@ CFLAGS+= -DNDEBUG
CONFIGURE_ENV+= EXTRA_PRE_CXXFLAGS="-std=c++14"
.endif
-.if empty(PORT_OPTIONS:MMODSECURITY3) && empty(PORT_OPTIONS:MPASSENGER)
+.if empty(PORT_OPTIONS:MMODSECURITY3)
CONFIGURE_ARGS+= --with-ld-opt="-L ${LOCALBASE}/lib"
.else
CONFIGURE_ARGS+= --with-ld-opt="-L ${LOCALBASE}/lib -lpcre"
diff --git a/www/nginx-devel/files/extra-patch-passenger_src_nginx__module_Configuration.c b/www/nginx-devel/files/extra-patch-passenger_src_nginx__module_Configuration.c
index 4958d721fd2b..3d18184dd55e 100644
--- a/www/nginx-devel/files/extra-patch-passenger_src_nginx__module_Configuration.c
+++ b/www/nginx-devel/files/extra-patch-passenger_src_nginx__module_Configuration.c
@@ -1,11 +1,27 @@
---- ../passenger-6.0.22/src/nginx_module/Configuration.c.orig 2024-05-29 12:56:52.144194000 -0400
-+++ ../passenger-6.0.22/src/nginx_module/Configuration.c 2024-05-29 12:58:07.308893000 -0400
-@@ -225,7 +225,7 @@
+--- ../passenger-6.0.22/src/nginx_module/Configuration.c.orig 2013-10-26 20:00:00.000000000 -0400
++++ ../passenger-6.0.22/src/nginx_module/Configuration.c 2024-06-04 10:53:52.178855000 -0400
+@@ -224,8 +224,10 @@
+
conf->upstream_config.send_lowat = NGX_CONF_UNSET_SIZE;
conf->upstream_config.buffer_size = NGX_CONF_UNSET_SIZE;
- #if NGINX_VERSION_NUM >= 1007007
+- #if NGINX_VERSION_NUM >= 1007007
- conf->upstream_config.limit_rate = NGX_CONF_UNSET_SIZE;
++ #if NGINX_VERSION_NUM >= 1027000
+ conf->upstream_config.limit_rate = NGX_CONF_UNSET_PTR;
++ #elif NGINX_VERSION_NUM >= 1007007
++ conf->upstream_config.limit_rate = NGX_CONF_UNSET_SiZE;
#endif
conf->upstream_config.busy_buffers_size_conf = NGX_CONF_UNSET_SIZE;
+@@ -465,7 +467,10 @@
+ prev->upstream_config.buffer_size,
+ 16 * 1024);
+
+- #if NGINX_VERSION_NUM >= 1007007
++ #if NGINX_VERSION_NUM >= 1027000
++ ngx_conf_merge_ptr_value(conf->upstream_config.limit_rate,
++ prev->upstream_config.limit_rate, NULL);
++ #elif NGINX_VERSION_NUM >= 1007007
+ ngx_conf_merge_size_value(conf->upstream_config.limit_rate,
+ prev->upstream_config.limit_rate, 0);
+ #endif