aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-04-17 18:16:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-04-17 18:30:10 +0000
commit484cdffa84dd9b2f693fc0696c646b6bb614c9cb (patch)
tree03f0b417f5895a4612cffea440d8ab647d355109
parentb97627135c803704bc8ef92edd6aca617884552d (diff)
downloadports-484cdffa84dd9b2f693fc0696c646b6bb614c9cb.tar.gz
ports-484cdffa84dd9b2f693fc0696c646b6bb614c9cb.zip
x11-wm/gamescope: convert to cmake:indirect
-rw-r--r--x11-wm/gamescope/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index d2a413b1d1c0..731b5aaf759c 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -15,8 +15,7 @@ WWW= https://github.com/ValveSoftware/gamescope
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake-core \
- evdev-proto>0:devel/evdev-proto \
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
glslangValidator:graphics/glslang \
vulkan-headers>0:graphics/vulkan-headers \
wayland-protocols>=1.17:graphics/wayland-protocols \
@@ -31,7 +30,7 @@ LIB_DEPENDS= libdrm.so:graphics/libdrm \
libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= hwdata>0:misc/hwdata
-USES= compiler:c++11-lib meson pkgconfig sdl xorg
+USES= cmake:indirect compiler:c++11-lib meson pkgconfig sdl xorg
USE_GITHUB= yes
USE_SDL= sdl2
USE_XORG= x11 xcb xcomposite xdamage xext xfixes xmu xrender xres xtst xxf86vm
@@ -83,7 +82,6 @@ BUILD_DEPENDS+= ${CMAKE_BIN}:devel/cmake-core
USES+= llvm:min=16,build,export
PATH:= ${LLVM_PREFIX}/bin:${PATH} # XXX _CMAKE_TOOLCHAIN_SUFFIX vs. devel/llvm*
CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" CPP="${CPP}"
-CMAKE_BIN= ${LOCALBASE}/bin/cmake
# XXX Move into separate port and standardize via USES
GH_TUPLE+= llvm:llvm-project:llvmorg-16.0.1:libcxx