aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:04:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:57:52 +0000
commit489227db292b9d7426c04a8226edac4e5292dfb1 (patch)
tree27dc18f1aa76ed522c5280d8640a4c6a383b9d0e
parent4d156cad33888275e4bcf122f9fbc3ea8c36883c (diff)
downloadports-489227db292b9d7426c04a8226edac4e5292dfb1.tar.gz
ports-489227db292b9d7426c04a8226edac4e5292dfb1.zip
emulators/dosbox: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--emulators/dosbox/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index d549a8d9acce..61a22bec3ed4 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -13,20 +13,23 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
USES= cpe sdl
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-core-inline
+USE_CXXSTD= c++14
USE_SDL= sdl net sound
-PLIST_FILES= bin/dosbox man/man1/dosbox.1.gz share/pixmaps/dosbox.ico
-PORTDOCS= NEWS README
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-core-inline
DESKTOP_ENTRIES="DOSBox" "${COMMENT}" \
"${PREFIX}/share/pixmaps/dosbox.ico" "dosbox" \
"System;Emulator;" true
+PLIST_FILES= bin/dosbox man/man1/dosbox.1.gz share/pixmaps/dosbox.ico
+PORTDOCS= NEWS README
+
OPTIONS_DEFINE= DOCS
OPTIONS_RADIO= DEBUGGER
OPTIONS_RADIO_DEBUGGER=DEBUGGER_ENABLE DEBUGGER_HEAVY
+
DEBUGGER_ENABLE_DESC=Enable internal debugger
DEBUGGER_HEAVY_DESC=Enable internal debugger with extra features