aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-09-19 04:27:30 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-22 04:54:44 +0000
commit48c5dd95ac86d78830ef6ddb9617fb60c31e088c (patch)
tree3f2d10ef66876addaa0497dedb439406d9ecdd6e
parent5fd432e6a62a13abff8c5bc770fb57ef69519cb2 (diff)
downloadports-48c5dd95ac86d78830ef6ddb9617fb60c31e088c.tar.gz
ports-48c5dd95ac86d78830ef6ddb9617fb60c31e088c.zip
textproc/htmldoc: update to 1.9.17
Get rid of now obsolete workaround for clang 8 bug. Get rid of now obsolete GNUTLS option. Changelog: https://www.msweet.org/blog/2023-09-17-htmldoc-1.9.17.html
-rw-r--r--textproc/htmldoc/Makefile16
-rw-r--r--textproc/htmldoc/distinfo6
-rw-r--r--textproc/htmldoc/files/patch-htmldoc_ps-pdf.cxx15
3 files changed, 8 insertions, 29 deletions
diff --git a/textproc/htmldoc/Makefile b/textproc/htmldoc/Makefile
index 8699beb2110c..be9f380f05bd 100644
--- a/textproc/htmldoc/Makefile
+++ b/textproc/htmldoc/Makefile
@@ -1,6 +1,5 @@
PORTNAME= htmldoc
-PORTVERSION= 1.9.16
-PORTREVISION= 1
+PORTVERSION= 1.9.17
DISTVERSIONPREFIX= v
CATEGORIES= textproc
@@ -13,7 +12,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_mips= complains about expecting ) before png_ptr
-LIB_DEPENDS= libpng.so:graphics/png
+LIB_DEPENDS= libcups.so:print/cups \
+ libpng.so:graphics/png
USES= compiler:c11 cpe jpeg pkgconfig
CPE_VENDOR= ${PORTNAME}_project
@@ -22,18 +22,12 @@ GH_ACCOUNT= michaelrsweet
HAS_CONFIGURE= yes
-OPTIONS_DEFINE= GNUTLS HTMLDOCGUI
-OPTIONS_DEFAULT= GNUTLS
-
+OPTIONS_DEFINE= HTMLDOCGUI
HTMLDOCGUI_DESC= Build GUI front-end
-
-GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-GNUTLS_CONFIGURE_ENABLE= gnutls
-
HTMLDOCGUI_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
libfontconfig.so:x11-fonts/fontconfig
HTMLDOCGUI_USES= xorg
-HTMLDOCGUI_USE= XORG=x11,xcursor,xext,xfixes,xft,xinerama,xrender
+HTMLDOCGUI_USE= XORG=x11,xcursor,xext,xfixes,xft,xinerama,xpm,xrender
HTMLDOCGUI_CONFIGURE_WITH= gui=yes
post-install:
diff --git a/textproc/htmldoc/distinfo b/textproc/htmldoc/distinfo
index 87ca26e84c9f..78f2f13508c7 100644
--- a/textproc/htmldoc/distinfo
+++ b/textproc/htmldoc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1652990439
-SHA256 (michaelrsweet-htmldoc-v1.9.16_GH0.tar.gz) = f0d19d8be0fd961d07556f85dbea1d95f0d38728a45dc0f2cf92c715e4140542
-SIZE (michaelrsweet-htmldoc-v1.9.16_GH0.tar.gz) = 3416333
+TIMESTAMP = 1695096786
+SHA256 (michaelrsweet-htmldoc-v1.9.17_GH0.tar.gz) = 438cbd4c6673a9e156ef9a4793540762e8438298063cac019a45f55ac577872e
+SIZE (michaelrsweet-htmldoc-v1.9.17_GH0.tar.gz) = 3310895
diff --git a/textproc/htmldoc/files/patch-htmldoc_ps-pdf.cxx b/textproc/htmldoc/files/patch-htmldoc_ps-pdf.cxx
deleted file mode 100644
index 93762c943ced..000000000000
--- a/textproc/htmldoc/files/patch-htmldoc_ps-pdf.cxx
+++ /dev/null
@@ -1,15 +0,0 @@
-Workaround for potential optimizer bug in clang 8 that causes hangs at runtime
-
-https://github.com/michaelrsweet/htmldoc/issues/349
-
---- htmldoc/ps-pdf.cxx.orig 2018-04-10 11:56:03 UTC
-+++ htmldoc/ps-pdf.cxx
-@@ -5361,7 +5361,7 @@ parse_pre(tree_t *t, /* I - Tree to parse */
- line[10240],
- *lineptr,
- *dataptr;
-- int col;
-+ volatile int col;
- float width,
- height,
- rgb[3];